[Feature Request][Contacts] Please disable spelling Auto Correction for contact name fields

RESOLVED DUPLICATE of bug 1069830

Status

RESOLVED DUPLICATE of bug 1069830
4 years ago
4 years ago

People

(Reporter: jmitchell, Unassigned)

Tracking

({polish})

unspecified
ARM
Gonk (Firefox OS)
polish

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing])

(Reporter)

Description

4 years ago
Description:
It is very unlikely that the Auto correction will correctly handle Proper Names. It is MORE likely that it will incorrectly change a contacts name as the user enters it, creating a frustrating user experience and possibly causing them to enter and save incorrect data. The correction DOES handle normal / common names fairly well but will auto correct a lot of slang, abbreviations and nick-names. 


Repro Steps:
1) Update a Flame to 20150409010203
2) Launch Contact app
3) Select Create New contact
4) Enter the first name 'Emp' and hit space (just one example)


Actual:
Name is auto-corrected to 'Emo'


Expected:
No auto-correction. If I actually did know someone named 'Emp' it is very presumptuous to assume they would be 'Emo' 

Notes:

Environmental Variables:
Device: Flame 3.0 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150409010203
Gaia: 5dfd0460eb6e616205154b0d219aa5123bf1abb3
Gecko: 8f57f60ee58a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner for nomination and assignment for this feature request.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(jlorenzo)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
tracking-b2g: --- → backlog
Flags: needinfo?(jlorenzo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1069830
You need to log in before you can comment on or make changes to this bug.