An interactive Rocektbar appears briefly and disappears when rocketbar shouldn't appear at all.

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: nhirata, Assigned: apastor)

Tracking

({polish})

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments, 1 obsolete attachment)

1. turn sim pin lock on
2. skip SIM pin lock if it appears after reboot.
3. launch sms ; do not answer sim pin dialog
4. tap on rocketbar
5. type t
6. tap the google search (to switch the search engine; it doesn't switch due to bug 1150037)
7. tap on a search link
8. Sim lock dialog full screen should appear
9. tap the area where rocketbar might be in the status bar
10 quickly tap into the search bar and move the cursor
11: repeat 9 and 10

Expected : 9 shouldn't show anything to do with the rocketbar
Actual: shows the rocketbar and if you're quick enough you can interact with it


See bug 1150834
Flags: needinfo?(alive)
Flags: needinfo?(apastor)
Serial: 351dd0f2 (State: device)
Build ID               20150409010203
Gaia Revision          5dfd0460eb6e616205154b0d219aa5123bf1abb3
Gaia Date              2015-04-08 18:08:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8f57f60ee58a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150409.043639
Firmware Date          Thu Apr  9 04:36:48 EDT 2015
Bootloader             L1TC000118D0
(Assignee)

Updated

4 years ago
Assignee: nobody → apastor
Flags: needinfo?(apastor)
(Assignee)

Comment 4

4 years ago
Comment on attachment 8590767 [details] [review]
[gaia] albertopq:1152938-rocketbar-sim > mozilla-b2g:master

Again, not very happy about this kind of fixes, but we would need to remove the topPanel for fixing it properly. I'll create a separate bug for that.
Attachment #8590767 - Flags: review?(kgrandon)
(Assignee)

Updated

4 years ago
See Also: → 1153190
Seems Alberto is on it.
Flags: needinfo?(alive)
Comment on attachment 8590767 [details] [review]
[gaia] albertopq:1152938-rocketbar-sim > mozilla-b2g:master

Left a nit on github, but this looks good to me. Thank you!
Attachment #8590767 - Flags: review?(kgrandon) → review+
Whiteboard: [systemsfe]
Keywords: polish
Target Milestone: --- → 2.2 S10 (17apr)
I can still hit this issue with the patch.

commit 6ecbf3dd9e8a895daa8d82e1abd978478ee088aa
Merge: 3c68964 fc56a21
Author: nhirata <nhirata.bugzilla@gmail.com>
Date:   Fri Apr 10 14:30:23 2015 -0700

    Merge branch '1152938-rocketbar-sim' of http://github.com/albertopq/gaia int

See screenshot.
Flags: needinfo?(apastor)
(Assignee)

Comment 8

4 years ago
I guess the bug was still repro when clicking very fast on the title, so I added a new check.

Can you try again?

Thanks!
Flags: needinfo?(apastor) → needinfo?(nhirata.bugzilla)
Duplicate of this bug: 1152956
The check seemed to help.  I thought I got in a weird state before, but I can't reproduce it.
Tested in landscape/portrait. 

To note this doesn't address all instances of being able to tap on the rocketbar in the status bar and involve the rocketbar search.

( ie go to contacts -> import -> tap in that area).  see bug 1095168
Flags: needinfo?(nhirata.bugzilla)
(Assignee)

Comment 11

4 years ago
Ok, now it should fix all cases. Could you please check it again? Thanks for your help!
Flags: needinfo?(nhirata.bugzilla)
Duplicate of this bug: 1095168
There's a bit of animation after tapping contacts in the rocketbar, at the same time the rocketbar does show after a little while, so I guess it's ok?

ie. after step 5 from the comment 0, tap the contacts app to launch Contacts app.  You'll see a lot of animation occur on the status bar.  At the same time the rocketbar is accessible, and later on does show if you don't try tapping there.

Here's a video : https://www.youtube.com/watch?v=DR1Hj1ov9RY

I also tested around : https://bugzilla.mozilla.org/show_bug.cgi?id=1150834#c7

I think we're ok.  Thanks for all the fixes!  I closed out the other bug as a dup of this one since you fixed a lot of other side cases.
Flags: needinfo?(nhirata.bugzilla)
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Blocks: 1150834
(Assignee)

Comment 16

4 years ago
Blocking a blocker. We need this patch together with bug 1150834, as is causing bug 1154071.
blocking-b2g: --- → 2.2?
Blocking a blocker
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

4 years ago
No longer blocks: 1150834
Depends on: 1150834
(Assignee)

Comment 18

4 years ago
Comment on attachment 8590767 [details] [review]
[gaia] albertopq:1152938-rocketbar-sim > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: Clicking on the top panel while the search screen is active drives to bad UI (and weird auto-hide keyboard issues, see 1154071)
[Testing completed]: Added unit tests
[Risk to taking this patch] (and alternatives if risky):Given the tests coverage we have, I would say that is reasonably low risk
[String changes made]: -

* Note that we need to uplift bug 1150834 first to make this one apply.
Attachment #8590767 - Flags: approval-gaia-v2.2?(bbajaj)
(Assignee)

Updated

4 years ago
Attachment #8592773 - Attachment is obsolete: true
Attachment #8590767 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Flags: needinfo?(hcheng)
Naoki, I was trying to verify this issue, but unable to follow the STR since bug 1150037 is fixed now. Is there any other way to get to the fullscreen SIM PIN to repro this issue?
Flags: needinfo?(nhirata.bugzilla)
(Assignee)

Comment 21

4 years ago
I think that enabling and disabling airplane mode while the browser is open (and the chrome expanded), should do the trick
(In reply to Alberto Pastor [:albertopq] from comment #21)
> I think that enabling and disabling airplane mode while the browser is open
> (and the chrome expanded), should do the trick

I tried it, but the status bar with rocketbar appears on the SIM PIN screen, so I still cannot verify this issue.  Thanks for the tip though!
Not sure what you mean.  The fallouts from that bug is what this bug fixed.  If you can't repeat the steps and see the rocketbar with the steps in this bug, then you verified the fix.

I can still follow the steps and pull up the rocketbar sometimes.  you should see a weird graphics change.
See the video in comment 13
Flags: needinfo?(nhirata.bugzilla) → needinfo?(ychung)
I see. I was following the STR from Comment 0, and I was unable to reproduce step 6 and on. Sounds like the bug is not fixed yet.
Flags: needinfo?(ychung)
NM.  I didn't have the pull request from the other build.  I thought I did.

We'll just chalk this one up as can't verify due to different behavior.
QA Whiteboard: can't verfiy; change of behavior
(Assignee)

Comment 26

4 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #25)
> NM.  I didn't have the pull request from the other build.  I thought I did.
> 
> We'll just chalk this one up as can't verify due to different behavior.

I still think that the STR I gave, should reproduce the issue (without the fix)

1.- Go to the browser and open an scrollable page
2.- Scroll down in order to expand the chrome
3.- Enable airplane mode (via utility tray or long pressing power button)
4.- Disable airplane mode
5.- SIM Pin dialog will appear


We are now in the same state than step 9 on comment 0: Browser without visible rocketbar input and SIM dialog in top of it.
I believe that this issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results: The user is shown the SIM Pin dialogue, but cannot bring the Rocketbar up again until dealing with the SIM Pin dialogue.  Attempting to open it from the status bar results in it opening behind the SIM Pin dialogue completely (no way to interact with it and no visible status bar) instead of partially as in comment 0.  However the Rocketbar search bar goes from visible to not visible afterwards.

NI? Naoki to get his opinion.
	
Environmental Variables:
Device: Flame 3.0
BuildID: 20150421010201
Gaia: a8e4f95dce9db727dda5d408b038f97fb4296557
Gecko: 7b823253d9f2
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150421002501
Gaia: 828dd03a0e3b140d74b2e49355197df4d91d9227
Gecko: 36f72a3efb9b
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(ktucker)
Wow, ya.  I suppose that might be a separate bug.
I missed this case.  The browser can be scrolled up to see the rocketbar again.
Please file a separate bug, Jayme.
Flags: needinfo?(nhirata.bugzilla)
I've written that up separately as bug 1157535 per your suggestion Naoki.  Marking this bug as verified for now.
Status: RESOLVED → VERIFIED
Flags: needinfo?(hcheng)
QA Whiteboard: can't verfiy; change of behavior → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.