Closed Bug 1152956 Opened 6 years ago Closed 6 years ago

Rocketbar can get into a state of auto dismissing when invoking after hitting home button during the time the rocketbar is searching in the background.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1152938

People

(Reporter: nhirata, Assigned: apastor)

Details

(Whiteboard: [systemsfe])

1. turn sim pin lock on
2. skip SIM pin lock if it appears after reboot.
3. launch sms ; do not answer sim pin dialog
4. tap on rocketbar
5. type te
6. tap the google search (to switch the search engine; it doesn't switch due to bug 1150037)
7. tap on a search link
8. Sim lock dialog full screen should appear
9. quickly tap the area where rocketbar might be in the status bar
10 quickly hit home while the search is still going on ( you can see the data transfer still occurring )
11. tap on the rocket bar

Expected: no auto dismissal.
Actual: rocketbar dismisses itself.

Serial: 351dd0f2 (State: device)
Build ID               20150409010203
Gaia Revision          5dfd0460eb6e616205154b0d219aa5123bf1abb3
Gaia Date              2015-04-08 18:08:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8f57f60ee58a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150409.043639
Firmware Date          Thu Apr  9 04:36:48 EDT 2015
Bootloader             L1TC000118D0

Note I think this is a bug from the fix from bug 1150834
See video : https://www.youtube.com/watch?v=5jZZAzOAC0E
Flags: needinfo?(apastor)
Flags: needinfo?(alive)
Alberto could you handle this one?
Flags: needinfo?(alive)
Assignee: nobody → apastor
Flags: needinfo?(apastor)
Naoki, so if I don't get it wrong, the bug would be impossible to repro if the step 9 (which shouldn't happen, and it's getting addressed in bug 1152938) gets fixed? Can you try to find repro steps with the patch provided in bug 1152938?

Thanks!
Flags: needinfo?(nhirata.bugzilla)
I believe that to be the case, Alberto.  I'll check the patch, which might fix both of these issues.  Thanks for your quick response!
Whiteboard: [systemsfe]
I can still reproduce this case with the patch, though the patch doesn't completely conceal the rocketbar.
When the other bug lands and I can't repro this bug then I will close this as a dup of the other.
marking this as a dup of the other, as if there's no path to get to the steps mentioned, you can't reproduce this bug.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(nhirata.bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1152938
You need to log in before you can comment on or make changes to this bug.