[FxA] The home button will not work after signing into Firefox Acccounts

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: KTucker, Assigned: alive)

Tracking

({regression})

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

Description:
The home button will not respond after signing into Firefox Accounts. This happens after a factory reset or fresh flash. 


Repro Steps:
1) Update a Flame to 20150409010203
2) Flash the phone or factory reset the dut.
3) Enable data in the FTE then skip through the rest.
4) Open Settings and tap on Firefox Accounts.
5) Tap on "Create Account or Sign in" and enter a valid email address and password. 
6) Tap "Done" after logging in and try to tap the home button. 


Actual:
The home button will not respond after signing into FxA.


Expected:
The home button should always take the user home when pressed. 

Environmental Variables:
Device: Flame 3.0 (Full Flash)(KK)(319mb)
Build ID: 20150409010203
Gaia: 5dfd0460eb6e616205154b0d219aa5123bf1abb3
Gecko: 8f57f60ee58a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 100%
See attached: video clip, logcat
This also occurs on the Flame 2.2. 

The home button will not respond after signing into FxA.

Device: Flame 2.2 (Full Flash)(KK)(319mb)
BuildID: 20150409002503
Gaia: ea735c21bfb0d78333213ff0376fce1eac89ead6
Gecko: 0efd5cdbe224
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

--------------------------------------

This does not occur on the Flame 2.1

The user can return home without issue.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150409001200
Gaia: 87e55a7ec688138812181747f690fd188d2a0668
Gecko: b016448b6076
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Whiteboard: [3.0-Daily-Testing]
This is a regression and the user should always be able to return home when pressing the "Home" button so nominating this 2.2?
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
QA Contact: jmercado
The changes for bug 1147964 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150401182232
Gaia: 80575bc0b582d11971a49e8254522892874d1e3a
Gecko: aa869cc9fa8c
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150401201347
Gaia: f37be8b44cb7c3a147b9615ab76743b760f08eeb
Gecko: 3b226c00c741
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 80575bc0b582d11971a49e8254522892874d1e3a
Gecko: 3b226c00c741

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: f37be8b44cb7c3a147b9615ab76743b760f08eeb
Gecko: aa869cc9fa8c

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/80575bc0b582d11971a49e8254522892874d1e3a...f37be8b44cb7c3a147b9615ab76743b760f08eeb
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Alive, can you take a look at this please? Looks like the work done on bug 1147964 might have caused this to occur.
Blocks: 1147964
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(alive)
Okay, thanks!
Assignee: nobody → alive
Flags: needinfo?(alive)
blocking-b2g: 2.2? → 2.2+
The problem seems to be: FirefoxAccounts is stealing the focus even after it is closed. The evidence is when you touch the settings app, home button works again. I am not sure why it's regressed by bug 1147964.
Comment on attachment 8591517 [details] [review]
[gaia] alivedise:bugzilla/1153005/fxaccount-home > mozilla-b2g:master

The root cause is FindMyDevice got launched during the FxAccounts running - but we don't ignore this case so we don't re-focus AppWindowManager's Active app when FxAccounts is closed.
Attachment #8591517 - Flags: review?(etienne)
Comment on attachment 8591517 [details] [review]
[gaia] alivedise:bugzilla/1153005/fxaccount-home > mozilla-b2g:master

lgtm :)
Attachment #8591517 - Flags: review?(etienne) → review+
There are multiple oranges in the test result.. looking.
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #11)
> There are multiple oranges in the test result.. looking.

Fixed, a stupid bug :)
https://github.com/mozilla-b2g/gaia/commit/d7599cdbc23be867091063b2bc722adc0a474709
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8591517 [details] [review]
[gaia] alivedise:bugzilla/1153005/fxaccount-home > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): regression of 1147964 
[User impact] if declined: If there is a background app launching during the system dialog is shown, the hardware button will not work until user touches the app.
[Testing completed]: Y
[Risk to taking this patch] (and alternatives if risky): Simple check added, riskless I think.
[String changes made]: NaN
Attachment #8591517 - Flags: approval-gaia-v2.2?
Attachment #8591517 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Keywords: verifyme
This issue is verified fixed on Flame Master and 2.2.

Result: Homescreen displays properly when the user presses the home button after logging into FxA.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150415095209
Gaia: 2dd89fef4fae4d86fd313037ef384086c2e0e8a5
Gecko: 11077895df62
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150415002502
Gaia: 0b2e2f7c022554d57bf2afed36ba6788249197dd
Gecko: 2356b82e9a50
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → +QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.