[Flame][Settings]There is a "<" icon in Email login account page.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
10 months ago

People

(Reporter: wangxin, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8590602 [details]
Bug log: logcat_2051.txt

[1.Description]:
[Flame][v3.0][Settings]When you share files without email logged in, you will be blocked by login page. Then if you launch Email from Home, it is not a newly opened login account page. It directly goes to the view you were blocked with  "<" icon displayed.

Found Time: 20:51
See log: "logcat_2051.txt"
See video: "2051.MP4"

[2.Testing Steps]: 
Prerequisite: Don't log in Email account
1. Launch "Galleary"/ "Music"/"Video" or any other app which supports sharing file with Email.
2. Share a file with Email.
3. In login page, preess "Home" key.
4. Launch "Email".
5. Press "<" button.

[3.Expected Result]: 
5. A new login account page will be displayed, without the "<" icon when you launch Email app from Home.

[4.Actual Result]: 
5.  It is not a newly opened login account page. It directly goes to the view you were blocked with  "<" icon displayed.

[5.Reproduction build]: 
Flame 2.2(Unaffected):
Build ID               20150409002503
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0efd5cdbe224
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150409.041814
Firmware Date          Thu Apr  9 04:18:23 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(Affected):
Build ID               20150409160204
Gaia Revision          eaf69e651e19b98c096f8e63b9829fb31df50927
Gaia Date              2015-04-09 12:43:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd32e3ff3717
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150409.193255
Firmware Date          Thu Apr  9 19:33:06 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8590603 [details]
Bug video: 2051.mp4
(Reporter)

Updated

4 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
This occurs because the email manifest.webapp specified an "disposition": "window" for activities, which means it only allows one email window in firefox OS. This is done because of limitations of APIs in web workers. 

However, there is hope that during the 3.0 timeframe that we will get enough apis on workers and some other window messaging capabilities to go to an "disposition": "inline" activity, and this will address this issue.

The < (back) arrow behavior is different on master/3.0 than 2.2 and before because bug 1128739 got rid of the confirm prompt that used to prompt the user to set up an account.

End result, I expect this to improve once we can go disposition inline.

Comment 3

10 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.