Linear interpolation not displayed anymore in firefox for svg generated under pygal 1.7

RESOLVED DUPLICATE of bug 1149516

Status

()

defect
RESOLVED DUPLICATE of bug 1149516
4 years ago
4 years ago

People

(Reporter: xavier.guihot, Unassigned)

Tracking

37 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.90 MB, image/svg+xml
Details
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150402191859

Steps to reproduce:

Generate a SVG line chart with the pygal python library (version 1.7):

lineChart = pygal.Line(width=1100, height=600, interpolate='cubic',...)

And display it with Firefox and Google Chrome. It was well displayed in both Firefox and Google Chrome until April 09 2015. And since then, the linear interpolation has disappeared in Firefox.


Actual results:

With version 1.7 of the pygal python library, since April 9, in Firefox (not in Chrome), display of cubic linear interpolations has disappeared in svg graphs. Going back to an earlier version solved the problem. This issue has been addressed to pygal, but I also address it to Firefox because due to an upgrade by Firefox, the display has changed.
can you attach the SVG output of the pygal library as a testcase using the add an attachment button please?

Can you also check whether this bug exists in nightly https://nightly.mozilla.org/
Flags: needinfo?(xavier.guihot)
Posted image output.svg
The output example. The interpolation is visible under Chrome and IE but not anymore under Firefox.
Flags: needinfo?(xavier.guihot)
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149516
You need to log in before you can comment on or make changes to this bug.