Add keyboard layout for Frisian (fy)

RESOLVED DUPLICATE of bug 1160883

Status

defect
RESOLVED DUPLICATE of bug 1160883
4 years ago
4 years ago

People

(Reporter: fryskefirefox, Assigned: rudyl)

Tracking

unspecified
FxOS-S1 (26Jun)
x86_64
Windows Server 2003
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

1.18 KB, application/x-javascript
Details
Reporter

Description

4 years ago
Posted file fy.js
In preparation of adding a dictionary, I already would like to add the Frisian keyboard layout.
Reporter

Comment 1

4 years ago
Frisian wordslist is requested in https://bugzilla.mozilla.org/show_bug.cgi?id=1160883
Wim, 


Are you interested in making this a Gaia patch?
You could follow the guideline here and set the review flag to me,
https://github.com/mozilla-b2g/gaia/blob/master/CONTRIBUTING.md

Besides, you could try to modify the keyboard build integration as specified here,
https://github.com/mozilla-b2g/gaia/tree/master/apps/keyboard

If this is not in your area, please feel free to let me and I'll take over from here.
Thanks.
Flags: needinfo?(fryskefirefox)
Reporter

Comment 3

4 years ago
Hi Rudy Lu,
Although I could be able to work my way through the system of Gaia in Github, I'd prefer if you took it over, it probably will be much faster.
If you need any specific information, please don't hesitate to ask, I'd be more than happy to help.
Flags: needinfo?(fryskefirefox)
I'll take this.
Thanks for the info.
Assignee: nobody → rlu
Reporter

Comment 5

4 years ago
I am a bit unsure about the language code.
For Mozilla we always use fy-NL instad of fy, but I don't know if the code in fy.js has any unexpected effects when used in Firefox OS.
The app I made for testing didn't localize to Frisian for the settings part, so I guess I need to change languagecode there.
Still investigating...
Landed to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/b6c5fda821dce99babf8b9d5799a95eb4aeca64a
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Josh: can we get this approved to land on 2.2 please? As usual, it's minimal risk, this language has autocorrection already and is 100% complete + tested. So would be great for users to get that on 2.2 :)
thanks!
blocking-b2g: --- → 2.2?
Flags: needinfo?(jocheng)
Hi Rudy,
Please help to raise 2.2 uplift request. Thanks!
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(jocheng) → needinfo?(left.lu)
Rudy's gone. Is there someone else who can do the request?
Target Milestone: --- → FxOS-S1 (26Jun)
Duplicate of this bug: 1183775
Looks like everything has landed on master and 2.2 (dictionary and layout) in bug 1160883. Frysk layout on 2.2: https://github.com/mozilla-b2g/gaia/blob/v2.2/apps/keyboard/js/layouts/fy.js 

Marking as dupe to reflect that.
Flags: needinfo?(left.lu)
Resolution: FIXED → DUPLICATE
Duplicate of bug: Frisian-WordPrediction
However the fy layout has not been set by default for fy-NL locale: https://github.com/mozilla-b2g/gaia/blob/master/build/config/keyboard-layouts.json#L86

I'll do it in Bug 1183933.
You need to log in before you can comment on or make changes to this bug.