If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Editing a text node value in the inspector causes an exception

RESOLVED DUPLICATE of bug 1239047

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 1239047
3 years ago
2 years ago

People

(Reporter: pbro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
It's weird that this hasn't been reported so far, I've tested it back until FF37 and it happens there too.

STR:
- Open the inspector
- Find any text node you want in there
- Double-click to edit the content
- Change the text and press ENTER

The following exception is thrown:

*************************
A coding exception was thrown in a Promise resolution callback.
See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise

Full message: TypeError: this._inspector.change is not a function
Full stack: MarkupView.prototype.nodeChanged@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/markupview/markup-view.js:1208:7
TextEditor/<.done/</</</<@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/markupview/markup-view.js:2269:15
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:867:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:746:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:688:37
Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:688:5
this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:709:7
this.PromiseWalker.completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:671:7
Front<.onPacket@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/protocol.js:1217:7
DebuggerClient.prototype.onPacket@resource://gre/modules/devtools/dbg-client.jsm:953:7
LocalDebuggerTransport.prototype.send/<@resource://gre/modules/devtools/dbg-client.jsm -> resource://gre/modules/devtools/transport/transport.js:561:11
makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:82:14
makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:82:14

*************************

This doesn't break the inspector, the change is done correctly.

I have tried to hunt down the missing 'change' function in inspector-panel.js by going back in time, and couldn't find it, even going back as far as the ff21 tag.
Had a different exception on FF45 (TypeError: this.node.tagName is null markup-view.js:1867:9).
This was since fixed by Bug 1239047.

No more exception is logged on FF48.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1239047
You need to log in before you can comment on or make changes to this bug.