Crash on java.sun.com on linux

VERIFIED DUPLICATE of bug 105287

Status

Core Graveyard
Java: OJI
--
major
VERIFIED DUPLICATE of bug 105287
16 years ago
7 years ago

People

(Reporter: Yuying Long, Assigned: Joe Chou)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Build: 12-14, 12-13 linux trunk build on RH7.1-JA

Crash when try to load http://java.sun.com

Not reproduce on N6.2.1 RTM build.

No talkback window pops-up, the error message in terminal window:

# The exception above was detected in native code outside the VM
#
# Java VM: Java HotSpot(TM) Client VM (1.3.1-b24 mixed mode)
#
# An error report file has been saved as /tmp/hs_err_pid7040.log.
# Please refer to the file for further information.
#
INTERNAL ERROR on Browser End: Write failed. sendrequest
(Reporter)

Comment 1

16 years ago
I just noticed that it is an i18n issue - it crashes when locale set as
ja_JP.eucJP by default on my RH7.1-JA, but if I change locale to C, then won't
see this crash.

Change component to intl.
Component: Browser-General → Internationalization
(Reporter)

Comment 2

16 years ago
Reassign to Roy for now.
Assignee: asa → yokoyama
QA Contact: doronr → ylong
(Reporter)

Updated

16 years ago
Severity: normal → major
Keywords: crash
Summary: Crash java.sun.com on linux → Crash on java.sun.com on linux
(Reporter)

Comment 3

16 years ago
NO crash when locale set to en_US.  Maybe related with bug 115100.

Comment 4

16 years ago
linux-> simon
can you take a look at this?
Assignee: yokoyama → smontagu

Comment 5

16 years ago
I know what this is. Don't waste your time here. It is a Java VM problem under
JA locale. Reassing to JAVA components. 

This is the same crash right before we ship N6.1 or N6.2. 

The JavaVM on Linux do not like the ja version of the property file. 
Assignee: smontagu → ashuk
Component: Internationalization → Java APIs for DOM
QA Contact: ylong → avm

Comment 6

16 years ago
Reassigning to OJI module
Assignee: ashuk → joe.chou
Component: Java APIs for DOM → OJI
QA Contact: avm → pmac

Comment 7

16 years ago
reporter: could you please attach hs*.log file created by crashed jre?

Comment 8

16 years ago
Closing as dupe of bug 105287 because symptoms are the same.
Please compare hs*log files and reopen if they are different.

*** This bug has been marked as a duplicate of 105287 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

16 years ago
Yes, I checked the 2 .log files, looks like they are same crash.
Status: RESOLVED → VERIFIED

Comment 10

15 years ago
This bug can't reproduce on the following environment:
  Redhat 7.2, mozilla 1.0.1, jre1.4.0_03 and jre1.4.1_01 
  Redhat 8.0, mozilla 1.1, jre1.4.0_03 and jre1.4.0_02 
There are no crash and no error .

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.