[l10n][Cost Control]Arabic:The "Reset mobile & Wi-Fi data" is displayed with truncation in Reset data usage select view.

VERIFIED FIXED

Status

Mozilla Localizations
ar / Arabic
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Lancy(Leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 wontfix, b2g-v2.2 fixed)

Details

(Whiteboard: LocRun2.2, )

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8590739 [details]
Screenshot_Reset usage.png

[1.Description]:
[l10n][v2.1&v2.2][Cost Control]Arabic:Navigate throught the cost control FTE and enter settings, tap "Reset" value selector, the "Reset mobile & Wi-Fi data" is displayed with truncation.
See attachment:Screenshot_Reset usage.png

[2.Testing Steps]: 
Precondition: Have a SIM card in the device  
1.Set your phone language to Arabic.
2.Launch Usage.
3.Navigate throught the cost control FTE 
4.Tap the 'Settings' gear icon in the top right of the screen.
5.Tap "Reset" value selector.


[3.Expected Result]: 
5.The "Reset mobile & Wi-Fi data" should not be displayed with truncation.

[4.Actual Result]: 
5.The "Reset mobile & Wi-Fi data" is displayed with truncation.

[5.Reproduction build]: 
Device:Flame 2.1 build (Affected):
Build ID               20150409161204
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/81a3aad1e6d7
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150321.195232
Firmware Date          Sat Mar 21 19:52:42 EDT 2015

Device:Flame 2.2 build (Affected):
Build ID               20150409162502
Gaia Revision          df0e04acad7c8c993f6ffe07b0ccb0ec20ee50bb
Gaia Date              2015-04-09 22:35:05
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/091b1cc1240b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150409.200526
Firmware Date          Thu Apr  9 20:05:37 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
12838
(Reporter)

Updated

3 years ago
Whiteboard: LocRun2.2 → LocRun2.2, MGSEI-l10n-1F-Arabic
This same problem in different language need different RD to resolve.
See Also: → bug 1157174
Closing as dupe of Bug 1157174. Not an l10n issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1157174
Created attachment 8602500 [details]
Arabic_Reset mobile & Wi-Fi data.png

Hi Delphine,
This problem can be reproduced on latest user build of Flame2.1/2.2/3.0, and according to https://bugzilla.mozilla.org/show_bug.cgi?id=1157174#c30, may I know whether we can reopen this bug and keep it as l10n bug?
See screenshot of Flame2.1 and Flame 2.2: Arabic_Reset mobile & Wi-Fi data.png
Many thanks!
Flags: needinfo?(lebedel.delphine)
Yes Shine, correct, we can definitely re-open this bug given comment 30 in Bug 1157174. Let's wait for the patch there to land on 2.2 so localizer has an idea of how much he should try to shorten his string.
Flagging Rami, Arabic localizer, to see if he can shorten this string once Bug 1157174 lands on 2.2 branch as well. thanks!
Status: RESOLVED → REOPENED
Flags: needinfo?(lebedel.delphine) → needinfo?(rami223)
Resolution: DUPLICATE → ---
QA Whiteboard: [MGSEI-l10n-1F]
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Arabic → LocRun2.2,

Comment 5

3 years ago
I changed the text to make it shorter, so it should fix this issue
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(rami223)
Resolution: --- → FIXED
(Reporter)

Comment 6

3 years ago
Created attachment 8621466 [details]
Verify2_Arabic_v2.1_Fail_v2.2_Pass.png

Hi Rami,
This issue is verified pass on latest flame v2.2 user build in Arabic language, but still exist on latest flame v2.1 user build in Arabic language, could you confirm whether this issue will be fixed in 2.1 user build or not? many thanks! :)

See attachment:Verify2_Arabic_v2.1_Fail_v2.2_Pass.png.
Flame 2.1 Reproducing rate:10/10
Flame 2.2 Reproducing rate:0/10

Device: Flame 2.1 user build (Fail)
Build ID               20150611001204
Gaia Revision          f8b848c82d1ed589f7a1eb5cc099830c867ff1d4
Gaia Date              2015-06-08 09:48:23
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/7d767fc15126
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150611.034952
Firmware Date          Thu Jun 11 03:50:03 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user build (Pass)
Build ID               20150611162501
Gaia Revision          cfceba16e48ede3defee24be93637a0fa291c494
Gaia Date              2015-06-11 22:10:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3478f3c355c2
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150611.195442
Firmware Date          Thu Jun 11 19:54:53 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(rami223)
(Reporter)

Updated

3 years ago
QA Whiteboard: [MGSEI-l10n-1F] → [MGSEI-l10n-1F][MGSEI-Triage+]
status-b2g-v2.2: affected → fixed

Comment 7

3 years ago
Hi Lancy,
But why we are fixing also in 2.1? Firefox 2.1 localization is still not 100% completed the focus was on 2.2
Flags: needinfo?(rami223)
(Reporter)

Comment 8

3 years ago
Thanks for Rami's reply, so I change the flag of v2.1 from affected to wontfix.
Status: RESOLVED → VERIFIED
status-b2g-v2.1: affected → wontfix
You need to log in before you can comment on or make changes to this bug.