crash in android.content.res.Resources$NotFoundException: Resource is not a ColorStateList (color or path): TypedValue{t=0x2/d=0x101009b a=4} at android.content.res.Resources.loadColorStateList(Resources.java)

RESOLVED DUPLICATE of bug 1152337

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 1152337
3 years ago
3 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({crash})

38 Branch
All
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-062b7f14-f411-445f-8c4c-d71062150409.
=============================================================

android.content.res.Resources$NotFoundException: Resource is not a ColorStateList (color or path): TypedValue{t=0x2/d=0x101009b a=4}
	at android.content.res.Resources.loadColorStateList(Resources.java:1842)
	at android.content.res.TypedArray.getColorStateList(TypedArray.java:342)
	at android.widget.TextView.<init>(TextView.java:574)
	at android.widget.TextView.<init>(TextView.java:453)
	at java.lang.reflect.Constructor.constructNative(Native Method)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:415)
	at android.view.LayoutInflater.createView(LayoutInflater.java:505)
	at com.android.internal.policy.impl.PhoneLayoutInflater.onCreateView(PhoneLayoutInflater.java:56)
	at android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:568)
	at android.view.LayoutInflater.rInflate(LayoutInflater.java:623)
	at android.view.LayoutInflater.rInflate(LayoutInflater.java:626)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:408)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:320)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:276)
	at com.android.internal.policy.impl.PhoneWindow.setContentView(PhoneWindow.java:257)
	at android.app.Activity.setContentView(Activity.java:1716)
	at org.mozilla.gecko.overlays.ui.ShareDialog.onCreate(ShareDialog.java:170)
	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1047)
	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1666)
	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1722)
	at android.app.ActivityThread.access$1500(ActivityThread.java:124)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:974)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:130)
	at android.app.ActivityThread.main(ActivityThread.java:3821)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:507)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:839)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:597)
	at dalvik.system.NativeStart.main(Native Method)
Pretty confident on the dupe so please reopen if this is still an issue after bug 1152337 lands.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
See Also: bug 1152337
Duplicate of bug: 1152337
You need to log in before you can comment on or make changes to this bug.