background GIF in table isn't printed

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
--
major
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Alexis Hoang, Assigned: dcone (gone))

Tracking

Trunk
mozilla1.1alpha
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
1.  I put image as table background and text on top of it.  I.e. 
<table background='images/img1.gif'>  
  <tr>
     <td>
         <table>
             <tr>
                <td>text</td>
             </tr>
         </table>
     </td>
   </tr>
</table>
On the browser Netscape 6.1, the print outs are ok.  But using the new Netscape
browser 6.2, the image will not print, it only print out text.

2.  Using <Layer> or <p style=''> to align text on top of each image don't work
either.  Any ideas?
(Reporter)

Updated

17 years ago
Blocks: 115323
*** Bug 115323 has been marked as a duplicate of this bug. ***
Over to printing.
Assignee: jst → rods
Component: DOM Views and Formatting → Printing
QA Contact: stummala → sujay

Comment 3

17 years ago
confused here...are you talking about the HTML code you have included
or the website techcu.com....

please clarify.
(Reporter)

Comment 4

17 years ago
Created attachment 61814 [details]
shows the image background but does not print the image

Netscape 6.1 prints the background image for this page but not v6.2.
(Reporter)

Comment 5

17 years ago
Created attachment 61815 [details]
This image is part of file ShowImage.html

This image is part of the ShowImage.html page.
The background printing code has gotten a big revamp since Netscape 6.2.  Please 
test with 0.9.7 once it's out (the new code is not in 0.9.6) or test with a 
current nightly.

Comment 7

17 years ago
Confirming on Windows 98, 0.9.7, Build ID: 2002011803.

In trying to figure out what this bug report is saying, I went through the
following process. Download the text/html attachment. Name it "temp.html". Then,
download the image/gif attachment. Name it "temp.gif". Note that "temp.html" has
one reference to a gif file, "images/shrinked.gif." Make subdirectory "images".
Move temp.gif to images/shrinked.gif. Open temp.html. The text overlays the GIF.

In temp.html, the GIF is called by this HTML element:

<TABLE border='0' background='images\shrinked.gif'> 

Removing URL line:

http://www.techcu.com

since it appears to be unneeded. Also, changing the summary:

Old Summary: Printouts are not the same as viewing
New Summary: background GIF in table isn't printed

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Printouts are not the same as viewing → background GIF in table isn't printed

Comment 8

17 years ago
-->
Assignee: rods → dcone
Moz 1.1
Target Milestone: --- → mozilla1.1

Comment 10

16 years ago
is this still an issue ?

go into page setup and turn on the option for page bg color and images..


it should work after doing this...let us know...
(Reporter)

Comment 11

16 years ago
New Page Settings only works if you want to default to different color or 
image.  That's for user's settings.  Besides, it should 
print out exactly what appears on the screen.  Changing page settings will not 
solve this problem.
Alexis, by default we do not print background images or colors at all, since 
that would make many pages unreadable.  Hence sujay's asking you to go into 
page setup and turn _on_ background printing.  If it's off, background images 
will obviously not print.

Comment 13

15 years ago
Checking "Print background (Colors&images)" does not work as expected.

See the following URL :
http://members.tripod.com/andrei_b/elec/rc/rf-module/index.htm

While Print Preview renders this page correctly, actual printing does not. 
I checked on 2 printers with Mozilla 1.3b.

On a Lexmark CJ3200 I get the following:
The "A" in "Andrix Home", top left, is a GIF with transparency. It gets printed, 
but with white background. 
The TESTED circle on the right gets printed with white background.

On a HP-DJ125C I get the following:
The 2 images I mentioned earlier are NOT printed _at all_.
The image behind the text "Andrix Home", top left, is a table cell background.
It is not printed at all also.

Comment 14

14 years ago
wfm with mozilla 1.7/winxp and background image printing on.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.