Closed Bug 1153424 Opened 5 years ago Closed 5 years ago

flashing a build for the first time doesn't show any homescreen icons

Categories

(Firefox OS Graveyard :: GonkIntegration, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: nhirata, Assigned: wcosta)

References

Details

(Whiteboard: [spark])

Attachments

(2 files)

Attached file logcat of initial boot
1. flash the build from server
2. go through ftu ( turn on wifi )
Expected: Homescreen icons
Actual: just the rocketbar

Note:
1. you can search for the settings in the rocketbar and turn on adb
Attached file reboot logcat.txt
I rebooted the device and the icons are there.
logcat of that attached.

I think there might be some initialization that has to be done before the homescreen loads?  Not sure how I can delay the homescreen load after the very first flash of the device.
Priority: -- → P1
Whiteboard: [lightsaber]
Assignee: nobody → wcosta
Whiteboard: [lightsaber] → [ignite]
Whiteboard: [ignite] → [spark]
I think this is fixed now. Naoki, can you confirm?
Blocks: spark-ota
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(nhirata.bugzilla)
Resolution: --- → FIXED
I believe this is fixed as well. Esp for OTA.
Having said that, I'm waiting for full builds to be built : bug 1167266
Depends on: 1167266
Verified:

Gaia-Rev        0359bf81f96a5356dacfc07e12ca72df61cbd638
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/e537a1ba501b
Build-ID        20150526104411
Version         41.0a1
Device-Name     aries
FW-Release      4.4.2
FW-Incremental  eng.worker.20150526.102942
FW-Date         Tue May 26 10:29:49 UTC 2015
Bootloader      s1

Dogfood build :  https://tools.taskcluster.net/index/artifacts/#gecko.v1.mozilla-central.latest.linux.aries-dogfood/gecko.v1.mozilla-central.latest.linux.aries-dogfood.opt
Status: RESOLVED → VERIFIED
Flags: needinfo?(nhirata.bugzilla)
You need to log in before you can comment on or make changes to this bug.