[RTL] Arabic icon labels are LTR and ellipsize on left

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: sfoster, Assigned: sfoster)

Tracking

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

STR: 
1. Visit an arabic language page in browser
2. Use ... menu to 'Add to home screen' (أضِف إلى الشاشة الرئيسية )
3. Confirm the title in the prompt
4. Tap 'home' button to return to the homescreen

Expected: 
The icon label is in arabic script and truncated from the left. 

Actual:
The icon label is in arabic script and truncated from the right. 

I've confirmed in the IDE that this .title element has direction:ltr, not rtl as expected.
Adding Delphine for triage.
Flags: needinfo?(lebedel.delphine)
Please remember to attach your bugs to an rtl meta bug so this gets caught by triage :) thanks.
Triage P2 -- nominating 

Lancy: can you please make sure you have a test case for this?
blocking-b2g: --- → 2.2?
Flags: needinfo?(lebedel.delphine) → needinfo?(yulan.zhu)
Priority: -- → P2
(In reply to Delphine Lebédel [:delphine - use need info] from comment #2) 
> Lancy: can you please make sure you have a test case for this?

Hi Delphine,
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15480/
Flags: needinfo?(yulan.zhu) → in-moztrap+
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → sfoster
Assignee

Comment 5

4 years ago
Screenshot with LRT homescreen and mixed-language icons on left, RTL on the right
Assignee

Comment 6

4 years ago
> Screenshot with LRT homescreen and mixed-language icons on left, RTL on the
> right

Er. vice-versa. Arabic/RTL on the left, En-us on right.
Assignee

Comment 7

4 years ago
Comment on attachment 8592475 [details] [review]
[gaia] sfoster:homescreen-rtl-labels-bug-1153445 > mozilla-b2g:master

Just adding dir="auto" to the title/label of the grid icons. Didnt see the value in a test for this markup change, but can whip up one (I guess marionette and getComputedStyle(..).direction check?) if you prefer. Also, this seems like the only spot where the change is needed, is that right?
Attachment #8592475 - Flags: review?(kgrandon)
Comment on attachment 8592475 [details] [review]
[gaia] sfoster:homescreen-rtl-labels-bug-1153445 > mozilla-b2g:master

The code looks good to me. I can't really think of a solid test for this, and it seems fairly easy to regress/bypass a getComputedStyle check. Feel free to add one if you want, though I wouldn't consider it a blocker to landing.
Attachment #8592475 - Flags: review?(kgrandon) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Assignee

Comment 9

4 years ago
Comment on attachment 8592475 [details] [review]
[gaia] sfoster:homescreen-rtl-labels-bug-1153445 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): RTL/Homescreen
[User impact] if declined: In any locale, apps/icons on the homescreen in a RTL language get truncated and ellipsized from the right instead of left
[Testing completed]: Tested on device in en-US and ar as default locale, with a mix of english language and arabic icon labels
[Risk to taking this patch] (and alternatives if risky): V. Low, patch adds a single attribute to icon markup, don't anticipate any fallout. 
[String changes made]: None
Attachment #8592475 - Flags: approval-gaia-v2.2?
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Attachment #8592475 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Target Milestone: --- → 2.2 S10 (17apr)
This issue is verified fixed on Flame Master and 2.2.

Result: The Arabic title of a webpage added to the homescreen is truncated on the left side correctly.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150416010206
Gaia: 629097847567e51095a454e7e63186a6e2ac0307
Gecko: a35163f83d22
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150416002504
Gaia: 8e24d8b7f5e7c74c3004b22710dda0dac3e04ead
Gecko: 41388836b5c6
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.