Closed Bug 1153448 Opened 5 years ago Closed 5 years ago

L10N Plugincheck, locale missing, en-GB has become en-US

Categories

(www.mozilla.org :: L10N, defect)

Production
x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: dj.4bug, Unassigned)

References

()

Details

Plugincheck has had an "en-GB" locale for many years.
I don't know if the 'loss is a deliberate planned change'
or 'just an oversite'.
I also don't know if 'Mozilla wants this', the en-GB page, (e.g. for analytics).

I first noticed this regression at the end of March 2015.

See bug 1117189 comment # 8

> PS
> I was expecting to see a GB page for Plugincheck
> e.g.
> https://www.mozilla.org/en-GB/plugincheck/
> 
> but it is late here and I'll open another bug if this continues.

Using any version of 'en-GB' Firefox (Release, Nightly etc)
in "about:config" there is the following default:

"plugins.update.url", string,
"https://www.mozilla.org/%LOCALE%/plugincheck/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=plugincheck-update"

The "?utm_source" was introduced in July 2014 in
bug 1022745 "Add UTM parameters to plugincheck URL in Firefox"

See screenshot:
https://bug1084537.bugzilla.mozilla.org/attachment.cgi?id=8509897
shows an example of the 'en-GB' site, from October 2014, with the "?utm_source" in the URL.


STR:

Use any version of 'en-GB' Firefox.

First, check that
in "about:config" there is the following default:

"plugins.update.url", string,
"https://www.mozilla.org/%LOCALE%/plugincheck/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=plugincheck-update" 


A.
In "about:addons", at the top of the "Plugins" Tab.
If you 'click the link' "Check to see if your plugins are up to date".


Expected result
https://www.mozilla.org/en-GB/plugincheck/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=plugincheck-update

Actual result
https://www.mozilla.org/en-US/plugincheck/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=plugincheck-update

This is, I think, the way most users are 'expected to do a Plugincheck'
which is why the "?utm_source" is in the 'final URL'.


B.
in "about:plugins" click the link, at the top of the page,
"Find updates for installed plugins at mozilla.com/plugincheck"
[N.B. .com]

Expected result
https://www.mozilla.org/en-GB/plugincheck/

Actual result
https://www.mozilla.org/en-US/plugincheck/


C.
Navigate 'direct' (e.g. by typing into the Address bar) "mozilla.org/plugincheck"
[N.B. "mozilla.com/plugincheck" also does this].

Expected result
redirect to (like B above)
https://www.mozilla.org/en-GB/plugincheck/

Actual result
redirect to (like B above)
https://www.mozilla.org/en-US/plugincheck/



Also FYI,
If you 'try other languages' by going direct:

e.g.

https://www.mozilla.org/de/plugincheck/

https://www.mozilla.org/fr/plugincheck/

https://www.mozilla.org/it/plugincheck/

https://www.mozilla.org/ja/plugincheck/

https://www.mozilla.org/ru/plugincheck/

https://www.mozilla.org/uk/plugincheck/

https://www.mozilla.org/fa/plugincheck/

They work OK.


A few do redirect to a 'related locale':

e.g.
https://www.mozilla.org/pt/plugincheck/
redirects to
https://www.mozilla.org/pt-BR/plugincheck/

and
https://www.mozilla.org/es/plugincheck/
redirects to
https://www.mozilla.org/es-ES/plugincheck/

DJ-Leith
Thanks for the report,

I just checked with our L10n team and the en-GB translation for this page is no longer active, since it requires active translators to maintain the page. Until this happens and en-GB is activated again, bedrock will default to the next active locale in your accept language header.

https://l10n.mozilla-community.org/~pascalc/langchecker/?locale=all&website=0&file=mozorg/plugincheck.lang

Marking this bug as invalid for now.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.