Closed Bug 1153482 Opened 5 years ago Closed 5 years ago

The "Hamza-initial" letter arabic It does not appear correctly

Categories

(Core :: Graphics: Text, defect)

40 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: over68, Unassigned)

References

Details

The "Hamza-initial" letter arabic appears in isolated in the testcase https://dl.dropboxusercontent.com/u/95157096/85f61cf7/azmnx3ei9m.html.
Flags: needinfo?(jfkthame)
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=aa5e3b445810&tochange=ec10630b1a54

Triggered by:
550038369ab1	Jonathan Kew — bug 789687 - update harfbuzz to upstream commit fecdfa95daf4916695f23e7dab89ab363be11b89. r=jdaggett
When loading that testcase, I see a bunch of font errors reported in the Web Console:

downloadable font: Layout: glyph range is overlapping.in range 10 (font-family: "BoutrosAsmaRegular" style:normal weight:normal stretch:normal src index:0) source: https://dl.dropboxusercontent.com/u/95157096/85f61cf7/wiojnygw52.woff azmnx3ei9m.html:5:12
downloadable font: GDEF: Invalid glyph classes, table discarded (font-family: "BoutrosAsmaRegular" style:normal weight:normal stretch:normal src index:0) source: https://dl.dropboxusercontent.com/u/95157096/85f61cf7/wiojnygw52.woff azmnx3ei9m.html:5:12
downloadable font: Layout: Bad lookup flags 9 (font-family: "BoutrosAsmaRegular" style:normal weight:normal stretch:normal src index:0) source: https://dl.dropboxusercontent.com/u/95157096/85f61cf7/wiojnygw52.woff azmnx3ei9m.html:5:12
downloadable font: Layout: Failed to parse lookup 1 (font-family: "BoutrosAsmaRegular" style:normal weight:normal stretch:normal src index:0) source: https://dl.dropboxusercontent.com/u/95157096/85f61cf7/wiojnygw52.woff azmnx3ei9m.html:5:12
downloadable font: GPOS: Failed to parse lookup list table, table discarded (font-family: "BoutrosAsmaRegular" style:normal weight:normal stretch:normal src index:0) source: https://dl.dropboxusercontent.com/u/95157096/85f61cf7/wiojnygw52.woff azmnx3ei9m.html:5:12
downloadable font: Layout: Failed to parse lookup 4 (font-family: "BoutrosAsmaRegular" style:normal weight:normal stretch:normal src index:0) source: https://dl.dropboxusercontent.com/u/95157096/85f61cf7/wiojnygw52.woff azmnx3ei9m.html:5:12
downloadable font: GSUB: Failed to parse lookup list table, table discarded (font-family: "BoutrosAsmaRegular" style:normal weight:normal stretch:normal src index:0) source: https://dl.dropboxusercontent.com/u/95157096/85f61cf7/wiojnygw52.woff azmnx3ei9m.html:5:12

(Open the console, then click Shift-Reload to force the font to be reloaded rather than used from cache.)

Given that it looks like there are errors in the OpenType tables, it's not surprising the font doesn't shape correctly.

(And fwiw, it doesn't shape correctly in Chrome either.)
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jfkthame)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.