with cliget 1.2.2, "Save link as" is broken in Fx 38.0b2, 38.0b3

RESOLVED FIXED

Status

()

Firefox
Extension Compatibility
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: u43589, Unassigned)

Tracking

38 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150411015656

Steps to reproduce:

right click -> click "Save link as..."


Actual results:

Nothing


Expected results:

I should be prompted as to where to save the file.
(Reporter)

Updated

3 years ago
Summary: save link as broken in 38b2, 38b3 → "save link as" broken in 38b2, 38b3
(Reporter)

Comment 1

3 years ago
Works just fine in 37.0.1 etc.

Comment 2

3 years ago
Works for me with firefox-38.0b3.ru.linux64 and 2015-04-11-03-02-07-mozilla-central-firefox-40.0a1.en-US.linux-x86_64.

Does it depend on the build's language?
Flags: needinfo?(bugzilla)
(Reporter)

Comment 3

3 years ago
I run firefox built locally from source. This is the config i use:

    mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/firefox-shared
    mk_add_options MOZ_MAKE_FLAGS="$MAKEFLAGS -s"
    ac_add_options --prefix=/usr
    ac_add_options --with-system-jpeg
    ac_add_options --with-system-zlib
    ac_add_options --with-system-mng
    ac_add_options --with-system-png
    ac_add_options --with-system-nspr
    ac_add_options --with-system-nss
    ac_add_options --enable-system-ffi
    ac_add_options --enable-system-pixman
    ac_add_options --enable-system-sqlite
    ac_add_options --enable-system-cairo
    ac_add_options --with-pthreads
    ac_add_options --enable-optimize="$CFLAGS"
    ac_add_options --enable-official-branding
    ac_add_options --enable-extensions=default,-gnomevfs
    ac_add_options --enable-shared
    ac_add_options --enable-svg
    ac_add_options --enable-canvas
    ac_add_options --enable-crypto
    ac_add_options --enable-single-profile
    ac_add_options --enable-places
    ac_add_options --enable-storage
    ac_add_options --enable-places_bookmarks
    ac_add_options --enable-image-encoder=all
    ac_add_options --enable-xft
    ac_add_options --disable-static
    ac_add_options --disable-tests
    ac_add_options --disable-mochitest
    ac_add_options --disable-dbus
    ac_add_options --disable-debug
    ac_add_options --disable-installer
    ac_add_options --disable-updater
    ac_add_options --disable-xprint
    ac_add_options --disable-profilesharing
    ac_add_options --disable-gnomevfs
    ac_add_options --disable-gnomeui
    ac_add_options --disable-mailnews
    ac_add_options --disable-crashreporter
    ac_add_options --disable-necko-wifi
    ac_add_options --disable-libnotify
    ac_add_options --disable-gstreamer
    ac_add_options --disable-pulseaudio
Flags: needinfo?(bugzilla)
(Reporter)

Comment 4

3 years ago
I've used the same config for the past previous versions of firefox.

Comment 5

3 years ago
Does anything appear in the Browser Console? https://developer.mozilla.org/en-US/docs/Tools/Browser_Console
(Reporter)

Comment 6

3 years ago
I just downloaded and tried the official firefox 38b3 build for x86_64 and this is from stdout (sorry for omitting this in my earlier reports)

A coding exception was thrown and uncaught in a Task.

Full message: TypeError: gDownloadLastDir is undefined
Full stack: nsUnknownContentTypeDialog.prototype.promptForSaveToFileAsync/<@resource://gre/components/nsHelperAppDlg.js:295:7
TaskImpl_run@resource://gre/modules/Task.jsm:330:41
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:867:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:746:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:688:37

*************************

Comment 7

3 years ago
You can check
* your XDG settings (.config/user-dirs.dirs, $XDG_DOWNLOAD_DIR),
* the download setting at Preferences → General,
* if anything like AppArmor could be blocking access to some directory.

Comment 8

3 years ago
And are you using a profile manager to test with different/new profiles?
Flags: needinfo?(bugzilla)
(Reporter)

Comment 9

3 years ago
No, but I have now tested with a new profile and indeed, save link as works again.

So the question is, what breaks it? I doubt I will be the only one that hits this issue.
Flags: needinfo?(bugzilla)

Comment 10

3 years ago
Please see my comment 7.
Flags: needinfo?(bugzilla)
(Reporter)

Comment 11

3 years ago
Turns out it's caused by the extension "cliget" 1.2.2:

https://addons.mozilla.org/en-US/firefox/addon/cliget/
https://github.com/zaidka/cliget
Flags: needinfo?(bugzilla)
(Reporter)

Comment 12

3 years ago
reported here: https://github.com/zaidka/cliget/issues/17

Feel free to close if that's the policy for bugs caused by incompatible extensions

Comment 13

3 years ago
Thanks.
Component: Untriaged → Extension Compatibility

Updated

3 years ago
QA Whiteboard: [reported to upstream]
Summary: "save link as" broken in 38b2, 38b3 → with cliget 1.2.2, "Save link as" is broken in Fx 38.0b2, 38.0b3

Comment 14

3 years ago
Author of cliget here. The problem was a cliget issue and has been fixed. FYI, Cliget overrides external-helper-app-service and was not properly passing all function arguments to the original service.

Comment 15

3 years ago
Thanks, Zaid!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.