Closed Bug 1153501 Opened 7 years ago Closed 7 years ago

"More info" landing page for Push

Categories

(Core :: DOM: Push Notifications, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1169038
Tracking Status
firefox40 - ---
firefox41 + ---

People

(Reporter: dougt, Assigned: dougt)

References

Details

Attachments

(1 file)

The Push permission prompt has a "More info" link.  We need to build the content that describes what this feature is (similar to what we did with Geolocation).

The link we are currently pointing to ends up here:
     https://www.mozilla.org/en-US/firefox/push/
This should probably happen soon, since we're turning the feature on for Nightly and Aurora in bug 1153503, starting in 40, which we're rebuilding and enabling updates for today.
Flags: needinfo?(dougt)
Flags: needinfo?(dougt) → needinfo?(jrconlin)
As an update, we're chasing the parties responsible for getting that page published. We have the FAQ content written, but need to have the right people for things like internationalization and getting the page rendered.

bmaggs is working on finding these parties.
Depends on: 1169038
clearing need info. bug chain has more info.
As an FYI, I am now working on completing the MDN Push API reference (https://developer.mozilla.org/en-US/docs/Web/API/Push_API). I should have the landing page sorted out in the next couple of days, and the whole reference finished in a week or two.
No, really, bugzilla. Clear the needinfo because there's a bug chain.
Flags: needinfo?(jrconlin)
If I understand correctly bug 1153503, push notifications have been disabled in 40. Stop tracking.
Chris, FF41 is not on the Aurora channel and I am following up to see if this bug is fixed or not. I don't see much activity since early June on this one. Will the "fix" need an uplift to aurora when ready and stable? If yes, the sooner the better to keep the release quality stable.
Flags: needinfo?(cmills)
I'd just update the link to

https://developer.mozilla.org/en-US/docs/Web/API/Push_API

The API reference is finished, and it just needs a couple of demos and a tutorial, which we are working on adding this month. And it is much better than a 404.

Is that acceptable?
Flags: needinfo?(cmills)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1169038
cmills, I have a number of comments, how would you prefer I provide that feedback?  I'd edit the page directly, but I'd rather have some discussion about the changes.

I don't think that the MDN information is the right level of information for a released product, and we do actually have real text prepared.
Flags: needinfo?(cmills)
Hi Martin,

You can drop me feedback over email if you like (same as my bugzilla address) - any feedback is much appreciated.

Bear in mind that the API landing page is only supposed to cover high level concepts. One missing part of the puzzle is a "Using the Push API" article that I'm currently in the process of writing a decent demo for (I was also waiting for support to appear in Fx for a few things, such as PushMessageData methods, and SW notifications.)
Flags: needinfo?(cmills)
No longer depends on: 1169038
You need to log in before you can comment on or make changes to this bug.