[Flame][master] HTTP Auth dialog doesn't show text input fields

RESOLVED DUPLICATE of bug 1157128

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1157128
3 years ago
3 years ago

People

(Reporter: Robert Kaiser, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

3 years ago
[Blocking Requested - why for this release]:

On recent master/nightly builds on my Flame, the HTTP Auth dialog is not displaying any input fields (to enter username and password) but still shows all the text surrounding it.

STR:
1) Go to http://lantea.kairo.at/ (or install and launch Lantea Maps from Marketplace)
2) Tap the "Track" button on the top left (if it's not visible, tap anywhere to show UI)
3) Tap the "Upload" button in the foldout area
4) Tap "Upload Track" in the upload "dialog"

--> The HTTP Auth dialog appears, missing the input fields.


This probably broke somewhere in the very first days of April (slightly more than a week ago) but I thought it probably would be discovered in smoketests and fixed soon, so I waited with reporting.
Adding qa flags: Can we see if this affects 2.2, and when it broke?
Keywords: qawanted, regression, regressionwindow-wanted
Whiteboard: [systemsfe]
This is a dupe of bug 1157128.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted, regressionwindow-wanted
(Reporter)

Comment 3

3 years ago
(In reply to Pi Wei Cheng [:piwei] from comment #2)
> This is a dupe of bug 1157128.

Hrm, a dupe of a bug reported 10 days later than mine. I guess nobody actually looks at bugs people like me file. :(
I realized that too (that yours was filed earlier). But there has already been branch check and regression window done on that bug, so it seems reasonable in this case. You can always tag qawanted to confirm your bug and branch check upon writing up a bug, if you don't want to get future-duped.
(Reporter)

Comment 5

3 years ago
It's not a good sign that bugs that someone without knowledge of what exact flags to set are just ignored. Given that the new direction for Firefox OS includes a strong community, we should find out what we can do there, as community members will leave us very fast if the bugs they report get ignored and then forward-duped to something else.

That said, I'm happy for this specific one as long as we get a solution into master soon. ;-)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1157128
(Reporter)

Comment 6

3 years ago
Oh, it's also not a good sign btw if @mozilla.com people filing new bugs are not looking first if that issues is filed already.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: 3.0? → 3.0+
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #6)
> Oh, it's also not a good sign btw if @mozilla.com people filing new bugs are
> not looking first if that issues is filed already.

I'm sorry. I should have looked for duplicated bugs before I filed bug 1157128.
You need to log in before you can comment on or make changes to this bug.