Closed Bug 1153746 Opened 6 years ago Closed 3 years ago

[FFOS2.0][Woodduck]How to open adb in user mode when mobile starts.

Categories

(Firefox OS Graveyard :: Gaia::System, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: sync-1, Unassigned, NeedInfo)

References

Details

CONTACT INFO (Name,Phone number):
     Email: wenhui.xu.hz.com
     Mobile:13763065145
  DEFECT DESCRIPTION:
     How to open adb in user mode when mobile starts.
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
     We need to read /data/data/jrdro for adb swtich in user mode when mobile starts.
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Dear Mozilla
    is there any progress?
Hi Kai-Zhen,
Could you help to provide some instruction how to open adb in user mode?
Thanks!
Flags: needinfo?(kli)
Blocks: Woodduck
Two steps to enable adb.

1. Enable developer menu 
Settings -> Device information -> More information -> Developer Menu (checked)

2. Enable ADB in developer menu
Settings -> Developer -> Debugging via USB (select 'ADB' or 'ADB and DevTools')
Flags: needinfo?(kli)
Flags: needinfo?(sync-1)
Dear Mozilla
     Plase provide some instruction how to modify code to open adb in user mode.
     --We need to implement to read /data/data/jrdro for choosing adb on or off in user mode when mobile starts.
     Thanks.
Dear Mozilla
    is there any progress?
Dear Mozilla
    is there any progress?
Dear Mozilla
     Do it can implement to read /data/data/jrdro for choosing adb on or off
 in user mode when mobile starts?
Dear Mozilla
    is there any progress?
Dear Mozilla
     Plase provide some instruction how to modify code to open adb in user mode.
     --We need to implement to read /data/data/jrdro for choosing adb on or off
 in user mode when mobile starts.
     Thanks.
Dear Mozilla
    is there any progress?
Flags: needinfo?(kli)
Please reference comment 3 to enable adb in user build. But I didn't know exactly what is the requirement in comment 9.
Flags: needinfo?(kli)
Dear Mozilla
     抱歉,可能用英文表述需求不明确。
 
     我们的需求是把一个值写进/data/data/jrdro文件中作为打开adb的标志位,当手机开机时去读这个值判断是否打开adb,现在需要你们提供能确定在user版本打开adb的代码位置,我们好修改代码来实现这个功能。
     之前咨询过MTK,他们说需要你们确认,可否与MTK确认一下然后再提供解决方案,谢谢!
     
     MTK对应的bug是
 
     [SW] Bug#: 	974083
     MTK Issue ID: 	ALPS02031242
If you need to debug system hang issue, please enable adb in advance (per comment 3).
or there is no way to enable adb once hit hang.


There is no way for tester/user to enable adb after system hang cause adb is off, and no other way to access the device since console is off.
(In reply to comment #14)
 > Comment from Mozilla:If you need to debug system hang issue, please enable adb
 > in advance (per comment 3).
 > or there is no way to enable adb once hit hang.
 > 
 > 
 > There is no way for tester/user to enable adb after system hang cause adb is
 > off, and no other way to access the device since console is off.
 > 
 
 
 Dear Mozilla
     可否只告诉我们如何修改代码来在user版本打开adb吗?比如说在Settings -> Developer -> Debugging via USB 选择 'ADB only '后程序是在哪调用打开adb的,最好是能指出手机在开机时打开adb的程序代码(如eng版本)。
Dear Mozilla
     不太明白Comment #14的内容,可否留个电话,电话联系?
     请问以下我们所提的需求是否可实现:
     
     如何修改代码来在user版本打开adb吗?比如说在Settings
 -> Developer -> Debugging via USB 选择 'ADB only
 '后程序是在哪调用打开adb的,最好是能指出手机在开机时打开adb的程序代码(如eng版本)。
Dear Mozilla
    is there any progress?
    Would you please leave a contact number?
Dear Mozilla
    is there any progress?
    Would you please leave a contact number?
Dear Mozilla
    我们还没找到打开ADB的源码,我们的需求是需要贵司提供在user版本中打开adb的代码位置。就是说当我修改了那些代码,就可打开adb功能。
     若有疑问可电话联系。谢谢!
     Mobile:13763065145
Dear Dengwei
 
     The Issue need not to do for this project,please close it.
 
     Thanks!
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.