[SHB] Wrong dialog size on SIM PIN dialog with SHB enabled and landscape

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System::Window Mgmt
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: albertopq, Assigned: albertopq)

Tracking

unspecified
2.2 S10 (17apr)
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Assignee)

Description

3 years ago
STR:

1.- Start the phone with SHB enabled
2.- Skip SIM dialogs
3.- Open the browser app
4.- Enable airplane mode
5.- Disable airplane mode (SIM dialogs will be shown)
6.- Change orientation to landscape

Expected:

SIM PIN dialog resizes

Actual:

See screenshot
(Assignee)

Comment 1

3 years ago
Created attachment 8591572 [details]
2015-04-13-06-06-39.png
(Assignee)

Updated

3 years ago
blocking-b2g: --- → 2.2?
(Assignee)

Updated

3 years ago
Whiteboard: [systemsfe]
Ugh this seems like a regression. Didn't we pin the sim dialog to portrait only?
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → apastor
No we didn't.  We probably should, esp since the keyboard would cover the dialog anyhow.
asking fxos ux.

By the way, Alberto, what device are you testing on?  I can't repeat the gap that you show.
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(firefoxos-ux-bugzilla)
(Assignee)

Comment 4

3 years ago
It seems a regression that has been there for a while (Bug 1095805).

Naoki, I'm testing on a Flame with SHB enabled.

Thanks!
Created attachment 8592863 [details] [review]
[gaia] albertopq:1153779-sim-dialog > mozilla-b2g:master
(Assignee)

Comment 6

3 years ago
Comment on attachment 8592863 [details] [review]
[gaia] albertopq:1153779-sim-dialog > mozilla-b2g:master

As the child elements of dialog-overlay are .generic-dialogs, and [1] is already applying the 'right' value, I think that line is not needed anymore.

Is that correct, Kevin?

Thanks!

[1] https://github.com/mozilla-b2g/gaia/pull/29525/files#diff-76c229a6e5425345d3202703d8948d7aL32
Attachment #8592863 - Flags: review?(kgrandon)
Comment on attachment 8592863 [details] [review]
[gaia] albertopq:1153779-sim-dialog > mozilla-b2g:master

I am very concerned about breaking bug 1095805, especially without tests for both bugs (due to lacking b2g desktop landscape support). Code looks fine to me though, thanks.
Attachment #8592863 - Flags: review?(kgrandon) → review+

Comment 8

3 years ago
Can't repro, looks like a regression, suggest pin to portrait if possible and wouldn't block.
Flags: needinfo?(firefoxos-ux-bugzilla)
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

3 years ago
Comment on attachment 8592863 [details] [review]
[gaia] albertopq:1153779-sim-dialog > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1095805
[User impact] if declined: Dialogs in landscape with SHB on, are misplaced
[Testing completed]: Manual testing (we cannot test landscape in marionette)
[Risk to taking this patch] (and alternatives if risky): CSS one liner. Low risk
[String changes made]: -
Attachment #8592863 - Flags: approval-gaia-v2.2?(bbajaj)

Updated

3 years ago
Attachment #8592863 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/fa5444757443e6a5b652b92a00650bb070ad1a1e
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Target Milestone: --- → 2.2 S10 (17apr)
This issue is verified fixed on Flame Master.

Result: The SIM PIN dialog resizes.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150417010203
Gaia: 3cd0a9facce26c2acc7be3755a17131a6358e33f
Gecko: 51e3cb11a258
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

===============================
Adding verifyme for 2.2 verificaiton.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v2.2.
See attachment: verified_v2.2.mp4.
Reproduce rate: 0/5
Actual Results: The SIM PIN dialog resizes.

Device: Flame 2.2 build(Pass)
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.040848
Firmware Date          Sun Apr 19 04:08:59 EDT 2015
Bootloader             L1TC000118D0
status-b2g-v2.2: fixed → verified
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.