Please make about:performance update every ten seconds instead of every two seconds

VERIFIED FIXED in Firefox 40



Performance Monitoring
3 years ago
3 years ago


(Reporter: Jason Spiro, Assigned: wrahman0, Mentored)


40 Branch

Firefox Tracking Flags

(firefox40 fixed)


(Whiteboard: [lang=js])


(1 attachment)



3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150411030207

Steps to reproduce:

I visited the about:performance special page.

Actual results:

I discovered that the displayed information updates every 2 seconds. But it is too hard for me to read so fast.

Expected results:

Please update the information less frequently.  I suspect that every 10 seconds might be fine, though I haven't experimented to see whether or not this would be an acceptable update interval.

Comment 1

3 years ago
If you'd like to fulfill this feature request, please see line 157 of
<chrome://global/content/aboutPerformance.js>.  You'd probably want to
change the number 2000 to some higher number.
Component: Untriaged → Performance Monitoring
OS: Windows 8.1 → All
Product: Firefox → Toolkit
Hardware: x86_64 → All
Indeed, to fix this bug, it is sufficient to change a single file:

at the end of the file, replace `2000` with `10000`.
Mentor: dteller
Whiteboard: [lang=js][good first bug]

Comment 3

3 years ago
I have submitted patches to other projects before, but never to anything Mozilla-related.

Firefox is an established project, and so there's some established bureaucracy.  There's a learning curve involved in submitting patches to a project with established bureaucracy.  The Mozilla patch submission process, for example, includes more steps than the patch submission process for smaller projects.

Because I've been busy lately, it would be unwise for me to go through this learning curve at this time.

wrahman0, are you interested in submitting a patch?
Flags: needinfo?(wrahman0)

Comment 4

3 years ago
Sure Jason, it looks like a very minor modification. I can submit a patch for it later today.
Flags: needinfo?(wrahman0)

Comment 5

3 years ago
Created attachment 8592360 [details] [diff] [review]

Increased the setInterval from 2 sec to 10 sec.

Side note:
I was wondering about the purpose of the setTimeout that wraps the setInterval. Shouldn't calling setInterval( ... , 10000 ) be sufficient to make the page update every 10 sec?
Flags: needinfo?(dteller)
Attachment #8592360 - Flags: review?(dteller)
We display data on activity since the previous update. On startup, we immediately call `State.update()` to get initial data, then we wait a second before calling it again and displaying stuff. If we didn't wait one second, the calls to `State.update()` would be too close to each other, and our first dataset would be completely absurd.
Flags: needinfo?(dteller)
Comment on attachment 8592360 [details] [diff] [review]

Review of attachment 8592360 [details] [diff] [review]:

Looks good, thanks.
Attachment #8592360 - Flags: review?(dteller) → review+
Let's land this :)
Keywords: checkin-needed
(In reply to David Rajchenbach-Teller [:Yoric] (use "needinfo") from comment #8)
> Let's land this :)

aye sir :)
Assignee: nobody → wrahman0
Keywords: checkin-needed
Whiteboard: [lang=js][good first bug] → [lang=js][good first bug][fixed-in-fx-team]
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Whiteboard: [lang=js][good first bug][fixed-in-fx-team] → [lang=js][good first bug]
Target Milestone: --- → mozilla40

Comment 13

3 years ago
Thank you all!  In the latest nightly, about:performance is now much more usable.
Whiteboard: [lang=js][good first bug] → [lang=js]

Comment 14

3 years ago
Sweet! I think you will like the play/pause feature even more!
You need to log in before you can comment on or make changes to this bug.