[Contacts][Picture] When selecting a contact witha picture, the picture area will flicker black during the transition

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: dharris, Assigned: seth)

Tracking

({regression})

37 Branch
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], [gfx-noted], )

Attachments

(4 attachments)

Description:
There is a quick black flickering where the picture is located at the top of the screen. This black flickering only occurs during the transition into contact view when selecting a contact with a picture.

Prerequsite: Have a contact with a picture attached

Repro Steps:
1) Update a Flame to 20150413010203
2) Open contacts app
3) Select the contact with a picture
4) Observe picture area during transition


Actual:
There will be a black flickering where the photo is located


Expected:
No black flickering is seen


Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150413010203
Gaia: 3c68964cb9fdba7cf0f6829b7f44562acaf1f1d7
Gecko: 0a46652bd992
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Repro frequency: 9/10
See attached: Logcat, Video - https://youtu.be/kAPdltHOMv8
This issue DOES occur on Flame 2.2

There will be a black flickering where the photo is located

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150413002502
Gaia: cec00d643f517ffd96cde559cd3bbd43ab85816c
Gecko: 5005522fd68e
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

=========================================================================================

This issue does NOT occur on Flame 2.1

There is no flickering seen when selecting a contact with a picture

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150410001204
Gaia: bbe983b4e8bebfec26b3726b79568a22d667223c
Gecko: 81a3aad1e6d7
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner for nomination decision and assignment, it's a regression but quickly recovers.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]: Regression which can be visible by every user.

Not sure if this is a graphics or a panning and zooming issue.
blocking-b2g: --- → 2.2?
Component: Gaia::Contacts → Panning and Zooming
Product: Firefox OS → Core
Version: unspecified → 37 Branch
It could just as easily be a contacts app issue.
QA Contact: ychung
QA Contact: ychung
QA Contact: ktucker
I am not 100% sure that this is the correct regression window because there is a flicker that occurs when the contact picture loads on the last working build but it gets worse on the first broken build. 

On the first broken build it flickers black like what was stated in this issue. 

Mozilla Inbound

Last Working
Device: Flame 3.0
BuildID: 20150209232857
Gaia: 0cf517083f7eb5fc269e1236edba50534f65e3cd
Gecko: f97eece7bdb6
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken
Environmental Variables:
Device: Flame 3.0
BuildID: 20150209235157
Gaia: 0cf517083f7eb5fc269e1236edba50534f65e3cd
Gecko: 88682971f399
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working Gaia First Broken Gecko: Issue DOES reproduce
Gaia: 0cf517083f7eb5fc269e1236edba50534f65e3cd
Gecko: 88682971f399

First Broken Gaia Last Working Gecko: Issue DOES NOT reproduce
Gaia: 0cf517083f7eb5fc269e1236edba50534f65e3cd
Gecko: f97eece7bdb6

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f97eece7bdb6&tochange=88682971f399

This might have been caused by bug 1130707
Seth, can you take a look at this please? This possibly was caused or made worse by the work done for bug 1130707.
Blocks: 1130707
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(seth)
blocking-b2g: 2.2? → 2.2+
Based on regression window.
Component: Panning and Zooming → ImageLib
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing], [gfx-noted]
Assignee

Comment 8

4 years ago
(In reply to KTucker [:KTucker] from comment #6)
> Seth, can you take a look at this please? This possibly was caused or made
> worse by the work done for bug 1130707.

Does this problem go away if "image.mem.decode-on-draw-only" is set to false?

If so, we can probably just flip that pref.
Flags: needinfo?(seth)

Comment 9

4 years ago
ni KTucker per comment 8.
Flags: needinfo?(ktucker)
I set the image.decode-only-on-draw.enabled to false and yes the issue does go away. No black flickering was observed.
Flags: needinfo?(ktucker)
Assignee

Comment 11

4 years ago
I think it makes more sense to block bug 1129804 in that case. I'm going to back it out.
Blocks: 1129804
No longer blocks: 1130707
Assignee

Comment 12

4 years ago
I just backed out bug 1129804, so this should be fixed once everything gets merged around.

Comment 13

4 years ago
verifyme as comment 12.
Assignee: nobody → seth
Keywords: verifyme
Per Comment 12 and Comment 13,this bug should been fixed.

I can't repro this bug on latest Nightly Flame v3.0,but can repro on latest Flame v2.2.

-----------------------------------------------------------------
STR:
1.Create a new contact with a picture.
2.Open the contact.
**Results: 
The contact picture will not flicker on Flame v3.0.
The contact picture will flicker on Flame v2.2.

See attachment: verified_v3.0.MP4, logcat_1833.txt and verify_v2.2.MP4.
Reproduce rate: 2/5(v2.2), 0/8(v3.0)

----------------------------------------------------------------------------
Device: Flame 2.2 build(Fail)
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.035703
Firmware Date          Thu Apr 23 03:57:16 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Pass)
Build ID               20150423160207
Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gaia Date              2015-04-23 16:10:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.193607
Firmware Date          Thu Apr 23 19:36:18 EDT 2015
Bootloader             L1TC000118D0
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]

Comment 18

4 years ago
Resolved per comment 14.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
See Also: → 1207529
You need to log in before you can comment on or make changes to this bug.