Closed Bug 1154044 Opened 7 years ago Closed 7 years ago

[raptor] Code for task3 results comparison

Categories

(Firefox OS Graveyard :: Gaia::PerformanceTest, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rwood, Assigned: rwood)

References

Details

Attachments

(1 file)

Develop code for the third raptor task (determine results).

Create docker raptor-results image, and corresponding code to compare results from the specified two previously completed raptor tasks. Flag a regression if the p95 visuallyLoaded value increases by the specified threshold.
Eli, can you please give me a review of the results comparison code?

https://github.com/rwood-moz/raptor-results/blob/master/bin/compare-results.js
Flags: needinfo?(eperelman)
I couldn't leave notes since it's not a PR, so I made my own refactored version. I haven't tested this, but it represents how I would achieve the same thing given the same code.

https://gist.github.com/eliperelman/87b7fe74bbddddc2bdd4
Status: NEW → ASSIGNED
Flags: needinfo?(eperelman)
Hey Eli would you mind having a look at the updated code? I intergrated your suggetions (thanks) and sorry it's not in a PR, a bit rushed.
Attachment #8593347 - Flags: review?(eperelman)
Thanks Eli. Nits addressed and updated.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.