Forwarding multi-part MIME message viewed as Simple HTML omits message

RESOLVED DUPLICATE of bug 394322

Status

defect
RESOLVED DUPLICATE of bug 394322
4 years ago
11 months ago

People

(Reporter: bugzilla-mozilla, Unassigned)

Tracking

31 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Reporter

Description

4 years ago
I receive a multi-part MIME message containing `multipart/related' and `multipart/alternative' parts. The message contains an image and has a PDF attached. It is viewed in simple HTML mode (View > Message Body as > Simple HTML).

The problem: when I forward it, the attachment is retained but none of the message body is. Shift+Forward to compose in plain-text also truncates the message body. However, if I view the message as Original HTML, all parts of the message get forwarded.

Tested with inline forwarding only. The `View > Display attachments inline' option has no impact on the reported behavior.
Reporter

Comment 4

4 years ago
Do note the PDF data was scrubbed from example attachment messages so they may not render properly.

Comment 5

4 years ago
I wonder if there's any significant number of users still using Simple HTML, or if we could just rip it out. I don't think it's worth investing developer time into fixing this.

Updated

11 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394322
You need to log in before you can comment on or make changes to this bug.