Browse button to upload files is broken.

RESOLVED DUPLICATE of bug 918780

Status

()

RESOLVED DUPLICATE of bug 918780
4 years ago
a year ago

People

(Reporter: dave.computer, Unassigned)

Tracking

37 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150404092546

Steps to reproduce:

Visit a website containing a "Browse" button for uploading files.  Click on the button.

Sites tried include a webmail site, amazon.ca, and this bug-entry page: bugzilla.mozilla.org/enter_bug.cgi#h=bugForm|Firefox

Additional notes:
Using Firefox 37.0.1 on Arch Linux with XFCE.
Firefox can successfully open a file manager window to select a download location.


Actual results:

Nothing for the user.
The Browser Console indicates "TypeError: ev.popupWindowURI is null", each time the button is clicked.


Expected results:

A file picker window should open to allow a file to be selected.

Updated

4 years ago
Duplicate of this bug: 1154120

Comment 2

4 years ago
(In reply to dave.firefox from comment #0)
> The Browser Console indicates "TypeError: ev.popupWindowURI is null", each
> time the button is clicked.

That's what you get when you set dom.popup_allowed_events to an empty value in about:config.

Does it work if you do this?
1. In the address bar, paste the following, then press Enter:
about:config?filter=dom.popup_allowed_events
2. To bypass the warning, press the big button labeled “I'll be careful, I promise!”.
3. In the search results, if dom.popup_allowed_events appears with the status “user set”, right-click it and choose Reset.

If that preference is already at its default value, please check if you have the same problem when you start Firefox in a brand new profile.
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(dave.firefox)
(Reporter)

Comment 3

4 years ago
dom.popup_allowed_events was set to an empty string. After resetting the value, and restarting Firefox, the browse button worked in all websites I tested. I'm changing this bug to resolved, though I don't know how the value was deleted originally.

Thanks for your help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(dave.firefox)
Resolution: --- → INVALID

Comment 4

4 years ago
(In reply to dave.firefox from comment #3)
> dom.popup_allowed_events was set to an empty string. […]
> I don't know how the value was deleted originally.

Sometimes Firefox's pop-up blocker is too lenient, which is why some people and add-ons set dom.popup_allowed_events to an empty string. This blocks all pop-ups, including links with the target="_blank" attribute, and the file picker for upload fields.

You can add trusted sites to the exceptions list under Options/Preferences → Content [1] or you can use an add-on [2] to easily toggle the pop-up blocker setting.

> Thanks for your help.

You're welcome.

[1] https://support.mozilla.org/kb/pop-blocker-settings-exceptions-troubleshooting
[2] https://addons.mozilla.org/firefox/addon/strict-pop-up-blocker/
Component: Untriaged → DOM: Events
Product: Firefox → Core
Resolution: INVALID → DUPLICATE
Duplicate of bug: 918780

Comment 5

4 years ago
(In reply to Gingerbread Man from comment #4)

> Sometimes Firefox's pop-up blocker is too lenient, which is why some people
> and add-ons set dom.popup_allowed_events to an empty string. This blocks all
> pop-ups, including links with the target="_blank" attribute

If only this were true… ;-)

Comment 6

4 years ago
(In reply to Nicolas Barbulesco from comment #5)
> (In reply to Gingerbread Man from comment #4)
> 
> > Sometimes Firefox's pop-up blocker is too lenient, which is why some people
> > and add-ons set dom.popup_allowed_events to an empty string. This blocks all
> > pop-ups, including links with the target="_blank" attribute
> 
> If only this were true… ;-)

It is. You've said so yourself in bug 964492, comment 9, as did three other people including me. If you have something else to add, please do so in your own bug report instead of this unrelated one.

Comment 7

3 years ago
(In reply to Gingerbread Man from comment #6)

> (In reply to Nicolas Barbulesco from comment #5)
> > (In reply to Gingerbread Man from comment #4)
> > 
> > > Sometimes Firefox's pop-up blocker is too lenient, which is why some people
> > > and add-ons set dom.popup_allowed_events to an empty string. This blocks all
> > > pop-ups, including links with the target="_blank" attribute
> > 
> > If only this were true… ;-)
> 
> It is. You've said so yourself in bug 964492, comment 9, as did three other
> people including me.

This does not block "opening links", with attribute target="_blank". They still open outside of the current tab.

Comment 8

3 years ago
Should we not differentiate a 'click' on an <input type=file> tag from a 'click' on any other DOM object. The expected functionality of a browse button is to open a file-picker dialog box while blocking popups initiated by a DOM 'click' is expected to block non-inherent functionality from those DOM objects (namely, popups). As is right now, not including 'click' in the string for dom.popup_allowed_events string blocks the basic function of <input type=file>, an outcome that would not normally be expected by a user trying to block popups (which is probably why we have so many complaints/bugs that the browse button is not working in Firefox, even when entering safe-mode since dom.popup_allowed_events stays the same in safe mode).

In short:

If anything, not including 'click' in dom.popup_allowed_events should only block any user *attached* click events ('onclick' attributes, etc), but not the tag's inherent file-picker dialog functionality.
You need to log in before you can comment on or make changes to this bug.