Screenshot thumbnail does not appear on Edit Listing page

RESOLVED WORKSFORME

Status

Marketplace
Developer Pages
P2
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: bsilverberg, Unassigned)

Tracking

({regression})

2015-05-05
x86
Mac OS X
regression
Points:
---

Details

(Whiteboard: [fromAutomation][ktlo])

(Reporter)

Description

3 years ago
A bunch of our automated tests are failing because, after creating an app submission via the API, when visiting the Edit Listing screen for the app the screenshot thumbnail does not appear, but rather the loading spinner appears instead.

STR:
1. Create an app submission via the API
2. Log in to Marketplace
3. Visit the Edit Listing URL for the app (e.g., https://marketplace-dev.allizom.org/developers/app/test-app-1428976477/edit)

Expected result: The screenshot thumbnail appears normally, with the html element having the classes `preview-thumb` and `preview-successful`.
Actual result: The screenshot thumbnail appears as a loading spinner, with the html element having the classes `preview-thumb` and `preview-error`.
(Reporter)

Comment 1

3 years ago
I should have mentioned that this is happening on dev.
Assignee: nobody → kngo
Priority: -- → P2
Target Milestone: --- → 2015-04-21
(Reporter)

Comment 2

3 years ago
This is only happening on dev (i.e., not stage) and it is blocking most of our developer hub tests on dev.

Updated

3 years ago
Duplicate of this bug: 1157650
(Reporter)

Comment 4

3 years ago
Note that I am also seeing this same issue with a manually created app, so it's not just apps that have been created via the API.
Looks like a filesystem permission issue on dev like in bug  1158109, I can't reproduce now.
Assignee: kngo → nobody
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Target Milestone: 2015-04-21 → 2015-05-05

Comment 6

3 years ago
This is still reproducible on -dev : http://screencast.com/t/Ot63NjSiRyP
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

3 years ago
The tests that were failing because of this have been passing since April 27 (that's the problem with xfailing - sometimes it takes awhile to notice a test is xpassing), so I think this bug can be closed.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

3 years ago
This seems to be a problem again. See https://webqa-ci.mozilla.com/job/marketplace.dev.developer_hub/382/HTML_Report/ for some failing tests complete with screen shots.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Keywords: regression
Whiteboard: [fromAutomation] → [fromAutomation][ktlo]
Hrm... we are waiting 300 seconds and it *still* isn't showing up?
(Note: this is failing when app is added via API)
This appears to be passing at the moment, and I can't reproduce it on dev.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.