If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

UpdateTargetApzc does not match ESM behavior for wheel events

RESOLVED FIXED in Firefox 40

Status

()

Core
Panning and Zooming
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: dvander, Assigned: dvander)

Tracking

unspecified
mozilla40
Points:
---

Firefox Tracking Flags

(firefox40 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
When we create a wheel transaction with a confirmed target APZC, we walk the overscroll handoff chain to find the first scrollable target. We don't do the same thing with UpdateTargetApzc, which is a bug, since APZCCallbackHelper doesn't have enough information to determine whether the target will actually scroll.
(Assignee)

Comment 1

3 years ago
Created attachment 8592038 [details] [diff] [review]
fix
Attachment #8592038 - Flags: review?(bugmail.mozilla)
Attachment #8592038 - Flags: review?(bugmail.mozilla) → review+
(Assignee)

Comment 2

3 years ago
remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/c8a8ef456931
https://hg.mozilla.org/mozilla-central/rev/c8a8ef456931
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla40

Updated

3 years ago
Duplicate of this bug: 1150280
You need to log in before you can comment on or make changes to this bug.