Closed Bug 1154225 Opened 5 years ago Closed 5 years ago

JavaScript warning: chrome://browser/content/nsContextMenu.js, line 1523: SyntaxError: unreachable expression after semicolon-less return statement

Categories

(Firefox :: General, defect)

defect
Not set
Points:
3

Tracking

()

RESOLVED DUPLICATE of bug 1140725
Tracking Status
firefox40 --- affected

People

(Reporter: Gijs, Unassigned)

References

Details

No description provided.
Flags: qe-verify-
Flags: in-testsuite-
Flags: firefox-backlog+
(In reply to Marco Bonardo [::mak] from comment #1)
> same as bug 1140725?

In Nightly, chrome://browser/content/nsContextMenu.js line 1523 (the inFrame line) is:

>  toString: function () {
>    return "contextMenu.target     = " + this.target + "\n" +
>           "contextMenu.onImage    = " + this.onImage + "\n" +
>           "contextMenu.onLink     = " + this.onLink + "\n" +
>           "contextMenu.link       = " + this.link + "\n" +
>           "contextMenu.inFrame    = " + this.inFrame + "\n" +
>           "contextMenu.hasBGImage = " + this.hasBGImage + "\n";
>  },

I don't see how it can be ambiguous, and I don't see any return without semicolon... *scratch head*
(In reply to Avi Halachmi (:avih) from comment #2)
> I don't see how it can be ambiguous, and I don't see any return without
> semicolon... *scratch head*

Hmm.. the last warning/error on this at bug 1052467 happened on 2015-04-07, which happens to be the same date at which the fix for bug 1140725 landed.

So maybe it is indeed bug 1140725.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1140725
Blocks: 1052467
You need to log in before you can comment on or make changes to this bug.