Closed Bug 1154313 Opened 6 years ago Closed 6 years ago

Move sUsingHwc to gfxPrefs

Categories

(Core :: Graphics, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

Attachments

(1 file)

layers.composer2d.enabled is stored to sUsingHwc. It is used in nsWindow::GetComposer2D(). When the pref is disabled, the function returns nullptr. But Bug 1152135 request to get Composer2D even when the pref is disabled. Because Composer2D's buffer swap is need to be done even when HWC's fast composition is disabled.
I confirmed attachment 8592293 [details] [diff] [review] works on flame-kk.
Attachment #8592293 - Flags: review?(nical.bugzilla)
Attachment #8592293 - Flags: review?(mwu)
Assignee: nobody → sotaro.ikeda.g
Attachment #8592293 - Flags: review?(nical.bugzilla) → review+
Attachment #8592293 - Flags: review?(mwu) → review+
https://hg.mozilla.org/mozilla-central/rev/b2704413af48
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.