Off by one (rounding error?) on Mac OS X only

VERIFIED FIXED in Future

Status

()

VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: lordpixel, Assigned: dcone)

Tracking

Trunk
Future
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Well, this could be ImageLib, Layout or CSS, but I have a reproducable case
where Mac OS X's rendering is out by one pixel. The same effect does not occur
on Mac OS 9 or Windows.

See: http://pixel.recoil.org/ 
The logo "Lordpixel" doesn't quit meet up with its endcap on Mac OS X only.

This is a CSS float with a background image.

I'll also attach a screenshot
(Reporter)

Comment 1

17 years ago
Created attachment 61852 [details]
Shows the one pixel gap

Comment 2

17 years ago
Confirming with 2002010808 CFM build.
 Reporter please include build used to see the problem. do you also see 
this in mach-o builds ?
Also please add the css keyword.
Reassigning to Don.
Assignee: attinasi → dcone
Target Milestone: --- → Future

Comment 4

17 years ago
Here is another example of this css problem under Mac OS X Mozilla 0.97 & 0.98,
an object positioned with css "bottom: 0" (or any value for bottom) is always 1
pixel higher than it should be.

test example:
http://phpwiki.sourceforge.net/alpha/sidebar/RecentChanges

Look under the "Last edited on..." text at the bottom. Scroll the body up and
down and you will see the text showing through a 1-pixel sliver below the date.

Mozilla 0.98 Mac OS X carbon, Build ID: 2002020516

Comment 5

17 years ago
I have also noticed the same thing. See http://www.oneredfish.com/index2.html -
buttons on the rhs should be flush with bottom of table cell. I have also
noticed similar effects at apple.com. This bug does not appear in Netscape 6.2,
but does appear in chimera 0.2.1

Mozilla 1.0rc1 Mac OS X Carbon build 2002041712

Comment 6

16 years ago
Works for me in Release 1.2.1 in OS X 10.2.2

lord pixel - the logo lines up just fine.
phpwiki - alpha/sidebar no longer exists.
oneredfish - what buttons on the right side?

If there are no examples left, this should be resolved fixed.
(Reporter)

Comment 7

16 years ago
Yes, its been fixed for a while (I can verify I have not changed the page at 
all). I'd forgotten about this bug. -> Fixed by something
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
*** Bug 148446 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.