Investigate whether call to get all logins is the slow part of loading about:passwords

RESOLVED FIXED

Status

()

P2
normal
Rank:
25
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Margaret, Assigned: ally)

Tracking

(Blocks: 2 bugs)

35 Branch
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: manage:passwords)

(Reporter)

Description

4 years ago
Calling `Services.logins.getAllLogins()` from the console can be slow, which makes me wonder if this is part of our about:passwords problem.
(Assignee)

Updated

4 years ago
Assignee: nobody → ally
(Assignee)

Updated

4 years ago
Blocks: 1079403

Comment 1

4 years ago
Bill and I setting to P2
Priority: -- → P2

Updated

4 years ago
Whiteboard: manage:passwords

Updated

4 years ago
Blocks: 1167657
(Assignee)

Comment 2

3 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=8763b7f47c02

build & try run. Removing favicons from about:passwords entirely. 

mfinkle believes this is the root cause of slowness(as getAllLogins() does not need to pass through gecko for aboutPasswords.js and sqlite is about as fast as it can get when running in geckoland), so this patch should prove or disprove that hypothesis

Updated

3 years ago
Rank: 25
(Assignee)

Updated

3 years ago
Blocks: 1170786

Updated

3 years ago
Blocks: 1175279
(Assignee)

Comment 3

3 years ago
It sounds like everyone is now quite settled on sql as the underlying problem. bug no longer needed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.