Closed Bug 1154382 Opened 8 years ago Closed 3 years ago

group position may be not updated when screen reader is running

Categories

(Core :: Disability Access APIs, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1515186

People

(Reporter: surkov, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: access)

when JAWS or NVDA (sometimes) is running then setsize is not updated when items are moved to the second listbox

http://download.dojotoolkit.org/release-1.10.4/dojo-release-1.10.4/dijit/tests/form/test_MultiSelect.html
Marco, can you reproduce it?
Flags: needinfo?(mzehe)
Yes, I can definitely reproduce it. But only if moving single items. As soon as I move two or more items in one step, the correct count is restored. But if I remove one item from one list and add it to the other, the *decrease* by one item is not reflected. The *increase* in the other list is reflected. If I move more than one item, like two at one time, both counts are correct. The problem is always with *decreasing* the item from the list it is removed from. The list where the item is added is always updated correctly. So the trick is to get it right that one item is removed and the count decreases by 1.
Flags: needinfo?(mzehe)
cannot reproduce, Marco, can you put here a log (shortest is best) with
export A11YLOG=tree;
Alex, does this export work on a regular release nightly build? Because that is where I am seeing this bug and can reproduce it.
(In reply to Marco Zehe (:MarcoZ) from comment #4)
> Alex, does this export work on a regular release nightly build? Because that
> is where I am seeing this bug and can reproduce it.

we were targeted at debug version but you could try, perhaps this makes a trick http://mxr.mozilla.org/mozilla-central/source/configure.in#8909

Can no longer reproduce. I'd say this is a duplicate of fixed bug 1515186.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.