Livedoor doesn't provide a favicon for mobile

ASSIGNED
Assigned to

Status

Tech Evangelism
Mobile
P5
normal
ASSIGNED
3 years ago
8 months ago

People

(Reporter: nhirata, Assigned: karlcow, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-jp] [favicon] [needscontact], URL)

Attachments

(1 attachment)

1. switch user agent using user agent switcher to firefox os (3.0)
2. goto http://www.livedoor.com/lite/

Expected: icon for the tab
Actual: no icon

Note: no icon for the bookmark on firefox os because of this.
I am referring to the favicon.  (forgot what it was called during the time I was writing the bug)
Summary: Livedoor doesn't provide a icon for mobile → Livedoor doesn't provide a favicon for mobile
Hi Naoko, can you give me the full user agent string you used? You can get it from echo.opera.com, for example. Or probably just navigator.userAgent from the DevTools console, if you're using a fake UA on desktop.

Thanks.
(Assignee)

Comment 3

3 years ago
So the markup is for both ios and firefox os

<link rel="shortcut icon" href="favicon.ico">
<link rel="apple-touch-icon" href="http://image.livedoor.com/img/top/lite/icon.png">

Interesting thing is that Firefox OS doesn't see it. And it's normal because

→ http HEAD http://www.livedoor.com/lite/favicon.ico
HTTP/1.1 302 Found
Connection: close
Content-Encoding: gzip
Content-Length: 20
Content-Type: text/html; charset=iso-8859-1
Date: Tue, 14 Apr 2015 23:58:58 GMT
Location: http://www.livedoor.com/
Server: Apache
Vary: Accept-Encoding


Request to the favicon is butchered. The real URI is 

→ http HEAD http://www.livedoor.com/favicon.ico
HTTP/1.1 200 OK
Accept-Ranges: bytes
Connection: close
Content-Encoding: gzip
Content-Length: 241
Content-Type: image/x-icon
Date: Tue, 14 Apr 2015 23:59:37 GMT
ETag: "37e-4b7e38c785c40"
Last-Modified: Wed, 01 Feb 2012 09:17:29 GMT
Server: Apache
Set-Cookie: ldsuid=42.145.168.181.1429055977388202; path=/; expires=Mon, 13-Jul-15 23:59:37 GMT
Vary: Accept-Encoding,User-Agent
X-XRDS-Location: https://auth.livedoor.com/openid/server.xrds



Then there is the apple one. This one exists. This is related to Bug 921014

→ http HEAD http://image.livedoor.com/img/top/lite/icon.png
HTTP/1.1 200 OK
Accept-Ranges: bytes
Cache-Control: max-age=2592000
Connection: close
Content-Length: 2858
Content-Type: image/png
Date: Wed, 15 Apr 2015 00:00:31 GMT
ETag: "b2a-4b7e394ef1bc0"
Expires: Fri, 15 May 2015 00:00:31 GMT
Last-Modified: Wed, 01 Feb 2012 09:19:51 GMT
Server: Apache
Set-Cookie: ldsuid=42.145.168.181.1429056031097588; path=/; expires=Tue, 14-Jul-15 00:00:31 GMT
(Assignee)

Updated

3 years ago
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
(Assignee)

Updated

3 years ago
Whiteboard: [country-jp] [favicon] [needscontact]
(Assignee)

Updated

3 years ago
Depends on: 998881
(Assignee)

Comment 4

3 years ago
yakura-san,

do you still have contacts with Livedoor?
They have a wrong redirection on their lite Web site.

Thanks.
Flags: needinfo?(myakura.web)
Created attachment 8592993 [details]
useragentswitcher.xml

Um, Naoki, not Naoko please.  

I attached the export of my useragent switcher.  I populated it based on whatismyuseragent.com.
Flags: needinfo?(nhirata.bugzilla)
Heh, typo. Sorry. Thanks for the xml file.
(Assignee)

Comment 7

3 years ago
Naoki-san,

so according to Comment #0 and the attachement, you have been using:

<useragent 
   description="Firefox OS 3.0" 
   useragent="Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0" 
   appcodename="Mozilla" appname="Netscape" 
   appversion="5.0 (Macintosh)" 
   platform="MacIntel" 
   vendor="" vendorsub=""/>

I'm testing with the same UA and I confirm my comment #3.
Not a Web Compatibility issue, but more wrong link. :)
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
(Assignee)

Updated

2 years ago
Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.