Closed Bug 1154447 Opened 5 years ago Closed 5 years ago

The arrow is missing from menu's "update available"-badge.

Categories

(Firefox :: Toolbars and Customization, defect)

39 Branch
x86_64
Windows 7
defect
Not set
Points:
1

Tracking

()

RESOLVED FIXED
Iteration:
40.2 - 27 Apr
Tracking Status
firefox38 --- fixed
firefox39 --- fixed
firefox40 --- unaffected

People

(Reporter: johan.charlez, Assigned: Gijs)

Details

Attachments

(2 files)

Attached image Screenshot of bug.
I've only seen this bug on the Aurora-channel so far.
Attachment #8592448 - Attachment description: Bug_Firefox_Menu-icon-badge--missing-arrow.png → Screenshot of bug.
We should have made a branch patch for 39. This is bug 1138630 getting broken due to the Windows theme refactorings. It's missing an aero asset, I bet.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 40.2 - 27 Apr
Points: --- → 1
Attached patch PatchSplinter Review
Approval Request Comment
[Feature/regressing bug #]: bug 1138630
[User impact if declined]: no update icon on win vista+
[Describe test coverage new/current, TreeHerder]: nope
[Risks and why]: none, including image asset into the aero side of the windows theme
[String/UUID change made/needed]: nope

Sylvestre, needinfo'ing because this is trivial and I'd like to just land this. See bug 1138630 for context - pretty sure it still has a comment where I told ntim his first patch was bitrotted by dao's theme refactor, and then now this uplift was being bitrotten by it.
Flags: needinfo?(sledru)
Attachment #8593235 - Flags: review+
Attachment #8593235 - Flags: approval-mozilla-beta?
Attachment #8593235 - Flags: approval-mozilla-aurora?
Specifically, bug 1138630 comment 8.
wfm!
Flags: needinfo?(sledru)
Attachment #8593235 - Flags: approval-mozilla-beta?
Attachment #8593235 - Flags: approval-mozilla-beta+
Attachment #8593235 - Flags: approval-mozilla-aurora?
Attachment #8593235 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.