Closed Bug 1154552 Opened 5 years ago Closed 5 years ago

about:plugin seems to break the back button by making it go to a page in a deleted forward branch in e10s windows

Categories

(Firefox :: Tabbed Browser, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1134518
Tracking Status
e10s m8+ ---

People

(Reporter: ehsan, Unassigned)

Details

The description of this bug weird, but the STR is simple:

1. Open a new tab (it is crucial to do that and not for example open a new window.)
2. Type about:support in the location bar and press enter.
3. Click on about:buildconfig.
4. Click Back.
5. Click on about:plugins.
6. Click Back.

You should be taken to about:support, but instead you're taken to about:buildconfig.  Pressing back again takes you to about:support.
Confirmed with STR's that this on e10s only.  

Note: after step 5, context click the Back button. Notice that about:buildconfig is in the list, before Troubleshooting Information.  about:buildconfig shouldn't be in the tab history at all, after step 4.

However, I am not able to reproduce this with regular web pages.
Something is going wrong copying the history to the new browser when we switch to remote for about:plugins. You casn reproduce this with a regular webpage if you change step 5 to "load any web URL".
I can no longer reproduce this using the STR from comment 0. ehsan, are you still seeing this?
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(ehsan)
Resolution: --- → WORKSFORME
Dave, could this be a dupe of that bug where the history overflows and then remoteness change gets broken? I wasn't able to find that bug in bugzilla.
Flags: needinfo?(dtownsend)
(In reply to Mike Conley (:mconley) - Needinfo me! from comment #3)
> I can no longer reproduce this using the STR from comment 0. ehsan, are you
> still seeing this?

No, I can't reproduce any more.
Flags: needinfo?(ehsan)
Sounds similar to bug 1134518 yes and the range seems to match.
Flags: needinfo?(dtownsend)
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1134518
You need to log in before you can comment on or make changes to this bug.