If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

UI widgets are NOT omitted from the Clipboard content

NEW
Unassigned

Status

()

Core
Selection
16 years ago
6 years ago

People

(Reporter: Jay Farrell, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    20011205

UI widgets are NOT correctly omitted from the Clipboard content, as this test 
says.




Reproducible: Always
Steps to Reproduce:
1.follow steps in http://www.mozilla.org/quality/browser/front-
end/testcases/copy-paste/copy-bad-stuff/copy-bad-stuff-d.html

Actual Results:  UI widgets are copied 

Expected Results:  The System Clipboard content should not contain any of the 
page's UI widgets (e.g. buttons, check boxes, etc.)


I was able to reproduce this on OpenVMS, build from 20011205, as well
as on a Linux machine I have.
Over to selection
Assignee: asa → mjudge
Status: UNCONFIRMED → NEW
Component: Browser-General → Selection
Ever confirmed: true
QA Contact: doronr → tpreston

Comment 2

16 years ago
copy != selection.
Target Milestone: --- → Future
(Reporter)

Comment 3

16 years ago
Just wanted to note I see the widgets if I paste into mail or composer, but
if I use a text editor on OpenVMS, I don't see the widgets. When I originally
tested/reported this, I was not using the text editor.
Assignee: mjudge → nobody
QA Contact: tpreston → selection
Matěj, can you reproduce this?

(Jay's address is dead)

Comment 5

6 years ago
Created attachment 548176 [details]
screenshot of the reproduction

Actually, I can. I have to use Thunderbird's compose window to enter HTML into the message, but then it is 100% reproducible.
You need to log in before you can comment on or make changes to this bug.