If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mach got Assertion even running "./mach help"

RESOLVED DUPLICATE of bug 1154002

Status

()

Core
mach
RESOLVED DUPLICATE of bug 1154002
3 years ago
3 years ago

People

(Reporter: bevis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I got following AssertionError in latest m-c synced last night, when running "./mach help" in my local emulator-ics build:

AssertionError

  File "/data/Projects/Builds/flame-kk/../../../../home/bevis/Projects/Builds/gecko/src/python/mach/mach/main.py", line 344, in run
    return self._run(argv)
  File "/data/Projects/Builds/flame-kk/../../../../home/bevis/Projects/Builds/gecko/src/python/mach/mach/main.py", line 390, in _run
    args = parser.parse_args(argv)
  File "/usr/lib/python2.7/argparse.py", line 1690, in parse_args
    args, argv = self.parse_known_args(args, namespace)
  File "/usr/lib/python2.7/argparse.py", line 1722, in parse_known_args
    namespace, args = self._parse_known_args(args, namespace)
  File "/usr/lib/python2.7/argparse.py", line 1931, in _parse_known_args
    stop_index = consume_positionals(start_index)
  File "/usr/lib/python2.7/argparse.py", line 1887, in consume_positionals
    take_action(action, args)
  File "/usr/lib/python2.7/argparse.py", line 1796, in take_action
    action(self, namespace, argument_values, option_string)
  File "/data/Projects/Builds/flame-kk/../../../../home/bevis/Projects/Builds/gecko/src/python/mach/mach/dispatcher.py", line 101, in __call__
    self._handle_main_help(parser, namespace.verbose)
  File "/data/Projects/Builds/flame-kk/../../../../home/bevis/Projects/Builds/gecko/src/python/mach/mach/dispatcher.py", line 253, in _handle_main_help
    instance = handler.cls(self._context)
  File "/data/Projects/Builds/flame-kk/../../../../home/bevis/Projects/Builds/gecko/src/layout/tools/reftest/mach_commands.py", line 463, in __init__
    MachCommandBase.__init__(self, context)
  File "/data/Projects/Builds/flame-kk/../../../../home/bevis/Projects/Builds/gecko/src/python/mozbuild/mozbuild/base.py", line 620, in __init__
    self.mozconfig
  File "/data/Projects/Builds/flame-kk/../../../../home/bevis/Projects/Builds/gecko/src/python/mozbuild/mozbuild/base.py", line 238, in mozconfig
    moz_build_app=os.environ.get('MOZ_CURRENT_PROJECT'))
  File "/data/Projects/Builds/flame-kk/../../../../home/bevis/Projects/Builds/gecko/src/python/mozbuild/mozbuild/mozconfig.py", line 237, in read_mozconfig
    parsed = self._parse_loader_output(output)
  File "/data/Projects/Builds/flame-kk/../../../../home/bevis/Projects/Builds/gecko/src/python/mozbuild/mozbuild/mozconfig.py", line 363, in _parse_loader_output
    assert current_type is not None
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1154002
You need to log in before you can comment on or make changes to this bug.