Can't close Preferences dialog after going to Appearance -> Fonts

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: arnoudb, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Steps to reproduce:
1) Open Prefs dialog
2) Go to Appearance -> Fonts
3) Hit Ok.

Result:
Nothing happens. The dialog doesn't close.
The JS Console shows this assertion:

Error: [Exception... "Component returned failure code: 0x8000ffff
(NS_ERROR_UNEXPECTED) [nsIPref.SetIntPref]"  nsresult: "0x8000ffff
(NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://communicator/content/pref/pref-fonts.js :: saveFontPrefs :: line 314" 
data: no]
Source File: chrome://communicator/content/pref/pref-fonts.js
Line: 314
(Reporter)

Comment 1

17 years ago
Oops, forgot to mention: this is with latest CVS build
(Assignee)

Comment 2

17 years ago
Reporter, 
Please use the bugzilla helper when reporting bugs.  I cannot reproduce this
problem on a current Win2K build.  I even tried changing my dpi setting since
the offending line of code appears to be triggered when the dpi setting is being
changed (or if you have a corrupt prefs.js file I suppose).  Could you reproduce
this with a new profile but the same build?  Also, probably irrelevant but what
platform are you on (Win2K as reported)?  Thanks.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
wfm using 12/14 bits.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.