Closed Bug 1154602 Opened 7 years ago Closed 7 years ago

Unable to open .html file via Dropbox Native App

Categories

(Firefox for Android Graveyard :: General, defect)

All
Android
defect
Not set
normal

Tracking

(firefox40 verified)

VERIFIED FIXED
Firefox 40
Tracking Status
firefox40 --- verified

People

(Reporter: capella, Assigned: mhaigh)

References

Details

Attachments

(1 file)

Since yesterdays nightly (at least) I've been unable to start Dropbox, select one of my test .html files and have it open in Nightly.

Logcat complains:

D/GeckoSharedPrefs(13906): Current version = 1, prefs version = 1
W/GeckoTabQueueDispatcher(13906): Unable to process tab queue insertion. No URL found! - passed data string: file:///storage/emulated/0/Android/data/com.dropbox.android/files/u146754915/scratch/BugCode/test_bug988143.html
Adding cc: for perhaps interested parties
Looks like TabQueueDispatcher only looks for web urls - assigning to mhaigh.
Assignee: nobody → mhaigh
Blocks: tab-queue
In hindsight the check we perform to see if there's a valid web url in the datastring is unnecessary.  This patch removes that check.

I also changed a finish to a return, as I'm in the file and this needed to happen anyway as the loadNormally function calls finish itself.
Attachment #8594247 - Flags: review?(michael.l.comella)
Comment on attachment 8594247 [details] [diff] [review]
Unable to open .html file via Dropbox Native

Review of attachment 8594247 [details] [diff] [review]:
-----------------------------------------------------------------

대박!
Attachment #8594247 - Flags: review?(michael.l.comella) → review+
Nice to see mcomella testing Firefox in Korean!
Status: NEW → ASSIGNED
Hardware: ARM → All
https://hg.mozilla.org/mozilla-central/rev/1fe6a64c60da
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Reproduced the issue on 14/04 build.
Using the 28/04 build, tapping a .html file from Dropbox and choosing to open with Nightly, will display "Tab queued in Nightly | Open now" toast notification. 
Verified as fixed using:
Device: Alcatel One Touch (Android 4.1.2)
Build: Firefox for Android 40.0a1 (2015-04-28)
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.