Paths with SVG-Markers are not rendered with Firefox 37.0.1

RESOLVED DUPLICATE of bug 1149516

Status

()

defect
RESOLVED DUPLICATE of bug 1149516
4 years ago
4 years ago

People

(Reporter: kleist, Unassigned)

Tracking

37 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.118 Safari/537.36

Steps to reproduce:

We have an App using SVG-markers with Paths to render arrows similar to the MDN-example https://developer.mozilla.org/en/docs/Web/SVG/Element/marker.

(on Windows)


Actual results:

Any SVG-Element with markers are not displayed at the given coordinates. Mostly nothing is displayed, sometimes only the markers are missing.


Expected results:

The SVG-Markers are displayed as in other browsers and previous Firefox versions.
Please add a testcase to the bug using the add an attachment link above.
Component: Untriaged → SVG
Product: Firefox → Core
Flags: needinfo?(kleist)
I have found the root cause of our problem after some try & error:

As a workaround for an older Chromium-bug for mixing dotted and solid paths we had to set stroke-dasharray="0" on the solid ones. 
Before version 37 and in other browsers this had the same result as stroke-dasharray="none". In Firefox 37 markers with stroke-dasharray="0" are not displayed.

Fortunately the Chromium-bug seems to have be fixed, so we can drop the workaround.
Flags: needinfo?(kleist)
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149516
You need to log in before you can comment on or make changes to this bug.