Closed Bug 1154637 Opened 6 years ago Closed 5 years ago

[RTL][Settings]Arabic: The text "3G" or "2G" is displayed at the wrong side of the word "preferred".

Categories

(Firefox OS Graveyard :: Gaia::Shared, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

RESOLVED INVALID
blocking-b2g 2.5+
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: lulu.tian, Assigned: autra, NeedInfo)

References

Details

(Whiteboard: LocRun2.2,)

Attachments

(4 files)

[1.Description]:
[l10n][v2.1 & v2.2][Settings]Arabic: The text of "3G" or "2G" is displayed at the right side of the word "preferred" in value selector at Network Operator view.
See attachment:wrong_position.png

[2.Testing Steps]: 
Precondition: Insert a SIM cards into device.
1. Set your phone language to Arabic. 
2. Launch Settings app. 
3. Tap "Cellular & Data". 
4. Tap "SIM 1" or "SIM 2". 
5. Tap "Network Operator" and observe the view. 

[3.Expected Result]: 
5. The text of "3G" or "2G" should be displayed at the left side of the word "preferred".

[4.Actual Result]: 
5. The text "3G" or "2G" is displayed at the right side of the word "preferred".

[5.Reproduction build]: 
Device: Flame 2.1 user (affected)
Build ID               20150414161204
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/3e3cbe35bce3
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.194039
Firmware Date          Tue Apr 14 19:40:50 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 (affected)
Build ID               20150414162502
Gaia Revision          16e948bfaaa15dbc0200135d52f16257b4eab193
Gaia Date              2015-04-14 21:08:25
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0eec28e78eb1
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.201515
Firmware Date          Tue Apr 14 20:15:24 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
When user select the Network Operator, the text in list are chaotic, the text at Network Operator view is same as that in select list.
Whiteboard: LocRun2.2 → LocRun2.2, MGSEI-l10n-1F-Arabic
This is NOT a truncation bug, nor is it l10n. Removing dependency, changing component
No longer blocks: 1118864
Component: ar / Arabic → Gaia::Settings
Product: Mozilla Localizations → Firefox OS
Blocks: settings-rtl
Summary: [l10n][Settings]Arabic: The text "3G" or "2G" is displayed at the wrong side of the word "preferred". → [RTL][Settings]Arabic: The text "3G" or "2G" is displayed at the wrong side of the word "preferred".
Attached image 2015-05-05-17-45-51.png
Please remember to always attach screenshots. 
Also, this could have been caught much earlier if it had been filed under the correct component. 
This still repros, please see screenshot attached. However I don't want to break string freeze, so not blocking on this for 2.2 release
3.0 would be a better option for getting a fix in, IMHO
triage P3 -- let's avoid breaking string freeze (see comment 2)
Priority: -- → P3
Duplicate of this bug: 1118453
After quite a bit of inspecting turns out is not a l10n issue but rather a Firefox OS issue.
Taking, will come up with a PR in a moment.
Assignee: nobody → nefzaoui
Comment on attachment 8601793 [details] [review]
[gaia] anefzaoui:bug-1154637 > mozilla-b2g:master

David, please review?

Thanks!
Attachment #8601793 - Flags: review?(dflanagan)
And a screenshot for the PR's result.
Component: Gaia::Settings → Gaia::Shared
Awesome, thanks Ahmed! :) Also, this won't break string freeze sooo... woohoo! \o/
Comment on attachment 8601793 [details] [review]
[gaia] anefzaoui:bug-1154637 > mozilla-b2g:master

I can't approve a last minute change to shared code like this. It seems risky to me. Also, I basically don't know anything at all about that CSS file, and I don't understand the bug or why this fixes it.  Perhaps you can find a reviewer who would be comfortable with the change, but from my standpoint, it just isn't a good idea to change shared code like this at the last minute.

Maybe you could patch the settings app to make those changes just for the one affected element?
Attachment #8601793 - Flags: review?(dflanagan) → review-
Also, when I try this out on master, using the mirrored runtime locale, I see the "3G" on the right, just like in the attached fixed screenshot.

So either this bug does not affect master, or it affects Arabic but not the mirrored locale.  And if it is the latter, then doesn't that suggest that it is an arabic localization bug rather than an RTL bug?
Switching the component back to Settings. Even though the proposed fix is in shared, the bug manifests in the Settings app.

Ahmed: if this really is a general bug in the shared CSS, please explain how it could manifest in other apps. If you really think this needs to be addressed as a shared CSS bug, go ahead and switch the component back (or maybe better to open a new bug for the general case).

It seems to me that the issue here is that you have text that appears to be bidi and you don't want to treat it as bidi, so you need a way to override the default.  But we can't just force all menu items to be ltr or rtl depending on the locale. That menu dialog is used for things like web activity pickers and it displays app names.  If an app does not provide an arabic localization, then its english name will be displayed. You wouldn't want that force to rtl, right? 

I suspect that the right fix here is an l10n one where you change the string to include characters that override the direction of the "3G" or change to a different translaton like "Use 3G preferentially" where "3G" is not the first character thing in the string.  I know you can't do that for this bug, but I think the proposed fix is heavy-handed and will break other things.
Hi William,
This Problem can be reproduced on latest build of Flame 2.2&3.0, The text "3G" or "2G" is displayed at the right side of the word "preferred".per comment10-12,Could you have someone to help with this bug? Many thanks!
----------------------------------------------
comment 12
> I suspect that the right fix here is an l10n one where you change the string
> to include characters that override the direction of the "3G" or change to a
> different translaton like "Use 3G preferentially" where "3G" is not the
> first character thing in the string.  I know you can't do that for this bug,
> but I think the proposed fix is heavy-handed and will break other things.
---------------------------------------------
This Problem cannot be reproduced on latest build of Nexus5 2.2&3.0, There is no 3G/2G on Nexus5 device, it is WCDMA/CDMA/EVDO/LTE..., and they are displayed at left side of the word "preferred".
See attachment:Nexus5.png
Device information:
Flame 2.2 Build ID: 20150526162504
Flame 3.0 Build ID: 20150526160204
Nexus5 2.2 Build ID: 20150526162504
Nexus5 3.0 Build ID: 20150526160204
Flags: needinfo?(whsu)
ni on Ahmed since he was looking into this
Flags: needinfo?(nefzaoui)
Remove NI because Delphine has provided enough information.
Flags: needinfo?(whsu)
QA Whiteboard: [MGSEI-l10n-1F][MGSEI-Triage+]
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Arabic → LocRun2.2,
[Blocking Requested - why for this release]:

Seems like this was dropped. Since we're past CC for 2.2, nominating this for 3.0 - in the case that this is still relevant in the upcoming release, which we still don't know much about
blocking-b2g: --- → 3.0?
Patrick, 

Can you verify if this issue still exists?

Thanks
Flags: needinfo?(pbylenga)
Keywords: qawanted
This issue is still reproducible on Flame 2.5 and 2.2. The screenshot at comment 2 is still happening. Unable to check this issue on Aries because all of the selections on my Aries SIM doesn't contain the word 'preferred' in Arabic.

Device: Flame 2.5
BuildID: 20150813030210
Gaia: 52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gecko: 7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Flame 2.2
BuildID: 20150812032504
Gaia: 102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gecko: 9295034c0ee3
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [MGSEI-l10n-1F][MGSEI-Triage+] → [MGSEI-l10n-1F][MGSEI-Triage+], [QAnalyst-Triage?]
Flags: needinfo?(pbylenga) → needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [MGSEI-l10n-1F][MGSEI-Triage+], [QAnalyst-Triage?] → [MGSEI-l10n-1F][MGSEI-Triage+], [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Dependency on 2.5 Feature. Blocker for 2.5
blocking-b2g: 2.5? → 2.5+
Hi Ahmed,
Just a soft reminder that we still observe the issue happen on 2.2 and 2.5 base on comment 19. Thanks
Status: NEW → ASSIGNED
Hi Josh,

This will most likely be fixed with the CSS refactor phase Phoxygen is working on, but I'm keeping it on my watch (won't remove my need-iinfo? flag) in case it doesn't. Thanks!
Ahmed/Josh, 

Any update on this one please? We are close to 2.5 RA.
Taking this to have a look.
Assignee: nefzaoui → augustin.trancart
To clarify: the expected form is when 3G is on the right side of the string. The initial comment said the contrary.

As this bug is for the "Operator" view, not the dropdown list, we'd better close this one and open another one.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.