[System] JSHint for system app after bug 1094759 landed

RESOLVED DUPLICATE of bug 1094759

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1094759
3 years ago
3 years ago

People

(Reporter: chens, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
We should fix all jshint error after bug 1094759 landed:

apps/system/js/browser_mixin.js
apps/system/js/icc.js
apps/system/js/init_logo_handler.js
apps/system/js/notification_screen.js
apps/system/js/orientation_manager.js
apps/system/js/payment.js
apps/system/js/sheets_transition.js
apps/system/js/update_manager.js
apps/system/js/wifi.js
apps/system/test/unit/app_install_manager_test.js
apps/system/test/unit/orientation_manager_test.js
apps/system/test/unit/update_manager_test.js
apps/system/test/unit/utility_tray_test.js
apps/system/test/unit/wifi_test.js
(Reporter)

Updated

3 years ago
Summary: [System] JSHint for marionette tests → [System] JSHint for system app
Summary: [System] JSHint for system app → [System] JSHint for system app after bug 1094759 landed
We have patches in progress for all other jshint failures except these last remaining system failures. It would be nice to fix these earlier if we can, maybe helping by rebasing bug 1094759 on top of them.
Sounds good. We will discuss this with alive.
(Reporter)

Comment 3

3 years ago
I have a wip based on alive's new-bootsrap-0424: https://github.com/mozilla-b2g/gaia/pull/29785
Hopefully we can land this patch right after new bootstrap lands.
(In reply to Sherman Chen [:chens] from comment #3)
> I have a wip based on alive's new-bootsrap-0424:
> https://github.com/mozilla-b2g/gaia/pull/29785
> Hopefully we can land this patch right after new bootstrap lands.

I guess what I was thinking is that depending on the ETA of that patch, we could do this first (and rebase the base module patch for him). I still have some other apps to get landed first though, and will revisit this when it's the last one left if it's still open.
I agree to fix this in my patch. Chens will send pull request to me so my patch will include his commit.
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1094759
You need to log in before you can comment on or make changes to this bug.