[SHB][Utility Tray] Notification tray is difficult to pull up if finger drags from bottom of screen (black SHB area)

RESOLVED DUPLICATE of bug 1100332

Status

RESOLVED DUPLICATE of bug 1100332
4 years ago
4 years ago

People

(Reporter: yi.zou, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master unaffected)

Details

(Whiteboard: [v2.2-nexus-5-l], [shb-enabled])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Nexus5 2.2][Homescreen] Pan down the screen,then you pan it up .Repeat these two stpes several times, then you are hard to pan up the screen successfully.
Time:19:36
See attachment logcat_1936.txt and 1936.mp4

[2.Testing Steps]: 
1.Pull down the notification.
2.Draw back the notification.
3.Repeat step1 and step2 several times.

[3.Expected Result]: 
3.You could draw back the notification successfully.

[4.Actual Result]: 
3.You can't draw back successfully.

[5.Reproduction build]: 
N5 v2.2 (Affected):
Build ID               20150414162502
Gaia Revision          16e948bfaaa15dbc0200135d52f16257b4eab193
Gaia Date              2015-04-14 21:08:25
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0eec28e78eb1
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150414.201650
Firmware Date          Tue Apr 14 20:17:04 EDT 2015
Bootloader             HHZ12f

N5 v3.0 (Unaffected):
Build ID               20150414160204
Gaia Revision          8e28588496f82f8f069c171c65842d622b9d8d7d
Gaia Date              2015-04-14 18:43:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/de27ac2ab94f
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150414.193923
Firmware Date          Tue Apr 14 19:39:38 EDT 2015
Bootloader             HHZ12f

Flame 2.2 (Unaffected):
Build ID               20150414162502
Gaia Revision          16e948bfaaa15dbc0200135d52f16257b4eab193
Gaia Date              2015-04-14 21:08:25
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0eec28e78eb1
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.201515
Firmware Date          Tue Apr 14 20:15:24 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 (Unaffected):
Build ID               20150414160204
Gaia Revision          8e28588496f82f8f069c171c65842d622b9d8d7d
Gaia Date              2015-04-14 18:43:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/de27ac2ab94f
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.194002
Firmware Date          Tue Apr 14 19:40:12 EDT 2015
Bootloader             L1TC000118D0
[6.Reproduction Frequency]: 
occasionally Recurrence,5/10

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8592763 [details]
1936.mp4
(Reporter)

Comment 2

4 years ago
Created attachment 8592764 [details]
logcat_1936.txt
(Reporter)

Updated

4 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → unaffected
Can we get a reverse regression window to see when this got fixed?
Keywords: qawanted
This issue is also reproducible on Flame. It happens when you enable software home button. Particularly if you put finger on the bottom black area and drag upwards. The device seems to ignore touches starting on the black area and so the pull is ignored. You can still pull up the tray by specifically NOT touching the bottom black area.

I'm working on the reverse window now.
Flags: needinfo?(ktucker)
Keywords: qawanted → regressionwindow-wanted
Summary: [Nexus5 2.2][Homescreen]You are hard to pan screen up successfully when you draw back the notification. → [SHB][Utility Tray] Notification tray is difficult to pull up if finger drags from bottom of screen (black SHB area)
Whiteboard: [v2.2-nexus-5-l] → [v2.2-nexus-5-l], [shb-enabled]
Component: Gaia::Homescreen → Gaia::System::Window Mgmt
QA Contact: pcheng
Flags: needinfo?(ktucker)
From the central pushlog I discovered that this bug was fixed in central by bug 1100332 and this bug should be marked as a duplicate of 1100332 because it's the exact same bug.

Central pushlog:
https://github.com/mozilla-b2g/gaia/compare/5dfd0460eb6e616205154b0d219aa5123bf1abb3...eaf69e651e19b98c096f8e63b9829fb31df50927
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → DUPLICATE
Duplicate of bug: 1100332
You need to log in before you can comment on or make changes to this bug.