Closed Bug 1154732 Opened 6 years ago Closed 6 years ago

Google search home screen shortcut displays blank page when opened

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox37 unaffected, firefox38+ wontfix, firefox39+ wontfix, firefox40+ wontfix, firefox41- affected, firefox42 affected, fennec+)

RESOLVED DUPLICATE of bug 1197176
Tracking Status
firefox37 --- unaffected
firefox38 + wontfix
firefox39 + wontfix
firefox40 + wontfix
firefox41 - affected
firefox42 --- affected
fennec + ---

People

(Reporter: TeoVermesan, Assigned: droeh)

Details

(Keywords: qawanted, regression)

Attachments

(1 file)

Steps to reproduce:
1. Tap on the URL bar. Type a search term with google (for e.g. "mozilla")
2. Long tap on the URL bar and choose "Add to Home Screen"
3. Tap on the device home button and open the URL shortcut created at step 2

Expected results:
- Firefox is opened and the page from step 1 is displayed

Actual results:
- A blank page is displayed
- Reloading the page does nothing
tracking-fennec: --- → ?
[Tracking Requested - why for this release]: Regression
Important regression, tracking.
Mark, do you know who could help on this issue? Thanks
Flags: needinfo?(mark.finkle)
We need a regression range. I would guess that the home screen shortcut just has the search term ("mozilla" from comment 0). We might be able to see that by inspecting the logcat the happens when the shortcut icon is tapped and Firefox is opened.

All that said, is this really an important regression? This is only broken for search queries, right?

I'd take a fix for it, but knowing the regression could make fixing it a bit easier.
Flags: needinfo?(mark.finkle)
OK, I just tried to reproduce this using Nightly. It worked fine for Google and Yahoo. Here are the logcat items I was looking for too:

I/ActivityManager(  375): START u0 {act=org.mozilla.gecko.BOOKMARK dat=https://search.yahoo.com/yhs/search?ei=UTF-8&hspart=mozilla&hsimp=yhsm-002&p=mozilla flg=0x10000000 cmp=org.mozilla.fennec/org.mozilla.gecko.BrowserApp bnds=[200,185][360,385]} from pid 16216

I/ActivityManager(  375): START u0 {act=org.mozilla.gecko.BOOKMARK dat=https://www.google.com/search?q=mozilla+&ie=utf-8&oe=utf-8 flg=0x10000000 cmp=org.mozilla.fennec/org.mozilla.gecko.BrowserApp bnds=[40,385][200,585]} from pid 16216

Teodora - Ca you retest and verify my results? I used a Galaxy Nexus on Android 4.3

Maybe some other fix landed recently and we could uplift it.
Attached file logs-google-homescreen
I have attached the logs while adding google search result to home screen and opening the shortcut.

I am still able to reproduce the issue on latest Nightly. I am using an Alcatel One Touch (Android 4.1.2)

Regression windows:
good build: 15-01-2015
bad build: 16-01-2015
pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c1f6345f2803&tochange=cac6192956ab

I am not able to reproduce the issue with yahoo search result.
Teodora - Can you get a regression range from mozilla-inbound or fx-team?
I cannot find a regression range for inbound or fx-team since the builds are no longer available. The oldest build is from 03/24/2015.
Assignee: nobody → mark.finkle
tracking-fennec: ? → 38+
I am afraid we will ship 38 with this issue.

FWIW, I had this issue once myself.
Is this fixed by bug 1158309 or bug 1150693? Teo would you try on a current nightly?
Flags: needinfo?(teodora.vermesan)
I am still able to reproduce the issue on latest Nightly (2015-05-06) using Samsung S5 (Android 4.4.2)
Flags: needinfo?(teodora.vermesan)
tracking-fennec: 38+ → +
We could still take a fix for this for 39 beta 4.   Mark did you have any luck reproducing it?
Flags: needinfo?(mark.finkle)
Keywords: regression
(In reply to Liz Henry (:lizzard) from comment #11)
> We could still take a fix for this for 39 beta 4.   Mark did you have any
> luck reproducing it?

Nope, and I don't have any time to work on it either. Assigning to a real dev.
Assignee: mark.finkle → mhaigh
Flags: needinfo?(mark.finkle)
Wontfix for 39. We could still take a patch for 40.
I wonder if this is the same as bug 1177414 in any way - seems similar
Margaret, I am considering dropping the tracking on this one as we already did two releases with this bug without critical fallout. Is that ok with you?
Flags: needinfo?(margaret.leibovic)
(In reply to Sylvestre Ledru [:sylvestre] PTO => August 1st from comment #15)
> Margaret, I am considering dropping the tracking on this one as we already
> did two releases with this bug without critical fallout. Is that ok with you?

Yes, that's fine.

But we should fix this. It seems like it's a platform issue... snorp, can you take a look at this?

I can't reproduce with other sites, so it seems like something specific to google.
Flags: needinfo?(margaret.leibovic) → needinfo?(snorp)
Given that reload (and presumably navigation?) have no affect, I think this may be some incarnation of our "blank content view" bug. Dylan, something is probably going wrong with getting hooked up to the EGL surface.
Assignee: mhaigh → droeh
Flags: needinfo?(snorp)
This bug is now wontfix for 40. 41 status is not marked. Is this still an issue with 41+?
This is reproducible on Firefox 41 and 42
Dylan, James, are there any plans to fix this bug for Fennec41? I trying to follow up on this issue as it's a tracked by for 41 and Fennec. Thanks.
Flags: needinfo?(snorp)
Flags: needinfo?(droeh)
I'm digging into this now, and certainly trying for a fix in time for 41.
Flags: needinfo?(droeh)
(In reply to Dylan Roeh (:droeh) from comment #21)
> I'm digging into this now, and certainly trying for a fix in time for 41.

Thanks Dylan. It would be ideal if the fix can be nominated for uplift by mid next week. Any later than that we would be getting too close to the RC 41 time frame when the bar goes very high.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(snorp)
Resolution: --- → DUPLICATE
Duplicate of bug: 1197176
qawanted to verify that this is not reproducible in nightly any more, and also to find a fix window. I'm not at all convinced that this is a dup of bug 1197176, although it may have been inadvertently fixed by other changes around the same time.
Keywords: qawanted
Teodora, would you be able to verify if this issue is fixed in a latest Nightly build? Thanks in advance.
Flags: needinfo?(teodora.vermesan)
Tested using:
Device: Nexus 4 (Android 5.1)
Build: Firefox for Android 43.0a1 (2015-09-02)

fix window:
24-08 build - affected
25-08 build - not affected

pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8a6045d14d6bd348a3b5bfeb55a9321e680cc93e&tochange=04b8c412d9f58fb6194c58dcaa66bf278bbd53cf

The fix for Bug 1197176 - Coming back to fennec from the task switcher sometimes doesn't repaint the content area was introduced in 24-08 build, but I am able to reproduce that google search home screen shortcut are still displayed as blank page when opened, with 24-08 build.
Flags: needinfo?(teodora.vermesan)
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.