If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When trying to renegotiate in FF37, a recvonly answer is created

RESOLVED WONTFIX

Status

()

Core
WebRTC: Signaling
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: Thomas Bruun, Unassigned)

Tracking

37 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8592822 [details]
Local and remote SDPs (candidates removed)

Steps to reproduce:

1. Open https://appear.in/someroomname in Chrome 41 and Firefox 37
2. Verify media flowing in both directions
3. Start screen sharing in Chrome

Expected result:
Firefox's setRemoteDescription fails because renegotiation isn't implemented in Firefox 37.

Observed result: 
Firefox's setRemoteDescription succeeds, and a new answer is created with a=recvonly for both video and audio.

Bonus step:
4. Refresh Chrome, and Firefox crashes.
Did you try 38? Renegotiation should work there. If you could try that with your setup and report here that would be helpful.

Also please let us know if the crash is reproducible, and please include the corresponding crashstats link from about:crashes if you could. Thanks!
(Reporter)

Comment 2

3 years ago
Firefox 38 works as expected (though the experience is not good due to Google's lack of support for multistream unified plan, which causes setRemoteDescription to fail when trying to renegotiate with both camera and screen streams).

The crash is reproducible, here is one of the crashstats links: https://crash-stats.mozilla.com/report/index/6cff041a-9bd6-4659-a521-f021a2150415
Thanks! Just to clarify is the crash reproducible in 38 as well, or just 37?
(Reporter)

Comment 4

3 years ago
Just 37
(In reply to Thomas Bruun from comment #2)
> Firefox 38 works as expected (though the experience is not good due to
> Google's lack of support for multistream unified plan, which causes
> setRemoteDescription to fail when trying to renegotiate with both camera and
> screen streams).

I'd imagine that massaging the SDP would be sufficient here.  Both Firefox and Chrome signal everything you might need to construct the SDP for the other.
(Reporter)

Comment 6

3 years ago
(In reply to Martin Thomson [:mt] from comment #5)
> I'd imagine that massaging the SDP would be sufficient here.  Both Firefox
> and Chrome signal everything you might need to construct the SDP for the
> other.

There's a discussion going on over at Chromium[0] suggesting that massaging the SDP might not be completely trivial, but it doesn't hurt to try.

[0] https://code.google.com/p/chromium/issues/detail?id=465349

Comment 7

2 years ago
Closing since 37 is no longer supported, and this seems to work in 38.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.