Status

()

Core
CSS Parsing and Computation
RESOLVED INVALID
17 years ago
15 years ago

People

(Reporter: Bob Kanefsky, Assigned: dbaron)

Tracking

({css2})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Mozilla 0.9.6 (2001112011)

Image clipping doesn't seem to work for the simplest test case I can think of:

<img src="http://roving-mouse.com/logos/roving-mouse-bbg-188x200.jpg"
     style="clip: rect(50px, 100px, 100px, 50px)">

I will attach a screen shot.
(Reporter)

Comment 1

17 years ago
Created attachment 61880 [details]
Screen shot of Mozilla and IE on same file
(Reporter)

Updated

17 years ago
Keywords: css2
Oh, boy... this is those clip errata from bug 87839 in action again...

The basic story (if I understand correctly) is that clip should either:

1) Be applied to elements that are block-level and absolutely positioned.  This
   is the "lost clip errata" version.
or
2) Be applied to all block or replaced elements, but only if overflow is not
   visible.  This is the "CSS2 spec as it stands" version.

In this case we have an <img> which is a replaced element, not a block.  It's 
not positioned.  Overflow is visible (default value).  So neither case #1 nor 
case #2 apply.  Looks like IE5/Mac implements a bastardization of the two 
cases...  <sigh>

We _really_ need this issue resolved by the working group.
Whiteboard: WG should decide what clip really means....again
(Assignee)

Comment 3

17 years ago
I think according to the latest discussion in the WG (this was resolved at our
latest meeting) this is a bug in IE5 Mac...
(Reporter)

Comment 4

17 years ago
Created attachment 61905 [details]
Three test cases

If I understand the preceding comments correctly, then all three test cases in
this attachment should cause clipping.	Only one of them does.

From the point of view of what I'm trying to implement, I'm happy to have found
one way to make it work in both IE and Mozilla (provided Windows IE behaves the
same way as Mac IE in this case).  From the point of view of correctness, it's
not clear whether Mozilla is following the standard, or even (given the
discussion in bug 87839 of the Lost Errata) what the standard is.  It would be
nice to have a clearly written interpretation of what the standard is, plus
some test cases showing how web page developers can use it.  Can someone
counter this attachment with a corrected version that will cause Mozilla to do
clipping as intended?
(Assignee)

Comment 5

17 years ago
No, the 'lost errata' clip applies only to absolutely positioned elements.
Perhaps my comment was unclear.  Mozilla (and Win IE6) implement the "lost 
errata" version of clip.  No browser implements the CSS2-compliant version, that 
I know.

David, should this just be invalid?  Is there a chance of official errata based 
on that last discussion?

Comment 7

16 years ago
Since this hasn't been looked at in a while, I just thought I'd point out that
this hasn't been fixed as of 1.3b.  There seems no way to clip an image that is
relatively positioned.  This is mostly useful to me for removing cgi-generated
borders and such.

Also note this is not Mac-specific.  Please update!
Ryan, you did read comment 4 and the bug referenced therein, right?  The WG has
not said anything useful since then.

Comment 9

15 years ago
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".
This is an XP issue in any case.
OS: Mac System 9.x → All
Hardware: Macintosh → All
In CSS2.1 it applies to absolutely positioned elements only. Since positioning 
an element makes it block-level, there is no inline ambiguity. HTH.
Whiteboard: WG should decide what clip really means....again
OK.  Then this bug is invalid.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.