All users were logged out of Bugzilla on October 13th, 2018

Sync displays a yellow bar error every hour of use till I reauthenticate.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: edwong, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
my old profiles seemed corrupt with authentication issues. so i started a new profile, and sync'd it and now I get an error every hour or so.

1. start with a clean profile.
2. "sign into sync" with an existing account - I can provide a test one if needed.
3. use the browser, after about 1 to 2 hrs

actual:
you'll get a yellow bar error and the following in an error.log

1429117317115	Sync.LogManager	DEBUG	Flushing file log
1429117317115	Sync.LogManager	TRACE	Beginning stream copy to error-sync-1429117317115.txt: 1429117317115
1429117317116	Sync.Service	DEBUG	Exception: Login failed: error.login.reason.account No traceback available
1429117317116	Sync.Service	DEBUG	Not syncing: login returned false.
1429117317209	FirefoxAccounts	INFO	Can't find the rest of the credentials in the login manager
1429117317397	Sync.LogManager	TRACE	finished copy to: /Users/Edwin/Library/Application Support/Firefox/Profiles/9k1t06qz.hardcore/weave/logs/error-sync-1429117317115.txt
1429117317397	Sync.LogManager	TRACE	onCopyComplete: 1429117317397
1429117317397	Sync.LogManager	TRACE	Scheduling cleanup.
1429117317397	Sync.LogManager	DEBUG	Log cleanup threshold time: 1428253317397
1429117318027	Sync.LogManager	DEBUG	Done deleting files.
1429120454310	Sync.SyncScheduler	DEBUG	Woke from sleep.
1429120454311	Sync.SyncScheduler	DEBUG	More than 1 client. Syncing.
1429120454311	Sync.Service	DEBUG	User-Agent: Firefox/38.0 FxSync/1.40.0.20150409144858.
1429120454311	Sync.Service	INFO	Starting sync at 2015-04-15 10:54:14
1429120454311	Sync.Service	DEBUG	In sync: should login.
1429120454312	Sync.Status	DEBUG	Status.service: error.login.failed => success.status_ok
1429120454312	Sync.Status	DEBUG	Status.service: success.status_ok => success.status_ok
1429120454315	Sync.Service	INFO	Logging in the user.
1429120454315	Sync.Service	DEBUG	Caching URLs under storage user base: https://sync-191-us-west-2.sync.services.mozilla.com/1.5/20817207/
1429120454337	FirefoxAccounts	INFO	Can't find the rest of the credentials in the login manager
1429120454337	Sync.BrowserIDManager	DEBUG	unlockAndVerifyAuthState re-fetched credentials and is returning: error.login.reason.account
1429120454338	Sync.Service	DEBUG	Fetching unlocked auth state returned error.login.reason.account
1429120454338	Sync.Status	DEBUG	Status.login: error.login.reason.account => error.login.reason.account
1429120454338	Sync.Status	DEBUG	Status.service: success.status_ok => error.login.failed
1429120454339	Sync.SyncScheduler	DEBUG	Clearing sync triggers and the global score.
(Reporter)

Comment 1

4 years ago
I pretty much see the yellow bar every day. I'm getting close to switching to Chrome! ;-)

this looks fishy:
1429117317209	FirefoxAccounts	INFO	Can't find the rest of the credentials in the login manager
I'm pretty sure you have some issues with your profile with being able to save the credentials into the password manager. It would be nice to get to the bottom of it, but have you tried creating a new profile and syncing your data to it?
Flags: needinfo?(edwong)
(In reply to Chris Karlof [:ckarlof] from comment #2)
> I'm pretty sure you have some issues with your profile with being able to
> save the credentials into the password manager. It would be nice to get to
> the bottom of it, but have you tried creating a new profile and syncing your
> data to it?

In comment 0:
(In reply to Edwin Wong [:edwong] from comment #0)
> my old profiles seemed corrupt with authentication issues. so i started a
> new profile, and sync'd it

So it looks like a new profile.  Is this nightly only? If so, I suspect bug 1153708.
(Reporter)

Comment 4

4 years ago
yes - this is a new profile.  I'm using Fx Beta
Flags: needinfo?(edwong)
(Reporter)

Comment 5

4 years ago
Fx38. Let me try Fx37
(Reporter)

Comment 6

4 years ago
with Fx37 - i need to reconnect sync but I don't see the yellow bar.
Closing this old bug
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.