Closed Bug 1154841 Opened 5 years ago Closed 5 years ago

Click-drag-select-releasing on a <select> element causes the <select> to always open on next click.

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s m7+ ---
firefox40 --- affected

People

(Reporter: mconley, Assigned: jimm)

References

(Blocks 1 open bug, )

Details

STR:

1) Visit data:text/html,<html><select><option>One</option><option>Two</option><option>Three</option></html>
2) Click on the <select> input, hold the click down, drag the cursor over one of the pop up items, then release on it.
3) Then click anywhere on the document _except_ for the <select>

ER:

Nothing.

AR:

The <select> opens again.

I can reproduce easily on OS X. I have not tried anywhere else.
tracking-e10s: --- → ?
This is potentially fallout from bug 1082510.
(I'm assuming STR step 0 is "make sure you have e10s enabled"? I get EXPECTED RESULTS on linux w/ e10s disabled, at least.)

With e10s enabled on Linux, I get odd (different) results:
 * During step 2 (while you're dragging cursor over the select options), the selected option does not change at all.
 * After you've released your initial click, *then* the select options will start being highlighted in response to your cursor position.
 * The popup menu remains open until you click again.

Then if I perform step 3 (clicking elsewhere), I get EXPECTED RESULTS (the <select> loses its focus ring, and nothing else happens).  But I think the behavior I'm observing before that is broken. Happy to spin off a separate bug for it, if you think it's unrelated-enough to the behavior described in comment 0.
I can't seem to reproduce this on OS X on a local m-c build in e10s mode.
Never mind, it's intermittent. I see it now.
Assignee: nobody → jmathies
OS: Mac OS X → All
I can no longer reproduce this on OS X. I'm not sure what fixed it.

dholbert - are you still seeing this too?
Flags: needinfo?(dholbert)
I'm still seeing what I described in comment 2, but I'll file another bug for it, since I think it's pretty different from your OS X issue (aside from having the same STR).
Flags: needinfo?(dholbert)
I filed bug 1159301 for the symptoms that I described in comment 2.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.