No easy way to report broken, abandoned add-ons to Mozilla

UNCONFIRMED
Unassigned

Status

UNCONFIRMED
4 years ago
3 years ago

People

(Reporter: higuita, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150414004003

Steps to reproduce:

I installed this add-on: https://addons.mozilla.org/en-US/firefox/addon/user-agent-rg  (but there are several add-ons that are broken, any one is a good example)



Actual results:

it does not work in current firefox versions and the comments are full of reports about that... yet, the add-on is still offered as valid to users

The end result is that with time, people start seeing more and more old broken add-ons and start losing faith on firefox add-ons store


Expected results:

Broken add-ons should not be offered and if installed should offer a easy way to flag it as broken. Developer can see those reports and agree to limit the compatibility of the add-on until new version, or sum several reports for auto-limiting or warn new users that it may not work... offer alternative add-ons would be even be better (could also be based on user comments)
This change could be in firefox or in the addons.mozilla.org  (or both)

Comment 1

4 years ago
(In reply to Daniel Mota Leite from comment #0)
> This change could be in firefox

Bug 565930.

> or in the addons.mozilla.org

Bug 336046.


Duping to the former, since the latter is marked FIXED.
Severity: normal → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
Resolution: --- → DUPLICATE
Duplicate of bug: 565930
(Reporter)

Comment 2

4 years ago
Sorry, but the Bug 336046 is for the add-on developer have a way to manage the support requests... in add-on https://addons.mozilla.org/en-US/firefox/addon/user-agent-rg/ i see no way to report anything to the author (probably because he abandoned it)... yet i still don't have a way to report that the add-on is broken  (other than spam the comments) and it will keep being offered to the other users.

we need a way to find and remove add-on that have since been abandoned and are now broken. A simple "report to the author" will still be ignored if the author doesn't care anymore. That is why we need something controlled by user feedback and mozilla and not just the author.

Thanks

Comment 3

4 years ago
(In reply to Daniel Mota Leite from comment #2)
> we need a way to find and remove add-on that have since been abandoned and
> are now broken. A simple "report to the author" will still be ignored if the
> author doesn't care anymore. That is why we need something controlled by
> user feedback and mozilla and not just the author.

So what you actually want is a way to report /abandoned/ add-ons to /Mozilla/. Updating summary.

Bug 565930 is the one for the Add-ons Manager; I'll ask if it would also handle this situation. This is then a report for the website side.


At the moment this is done by filing a new bug report here in Bugzilla. Most people don't even know about this site. That's how you end up with extensions that break essential functionality for 5 Firefox versions before the problem is addressed [1].

Each add-on details page has a “Report abuse” link. That link could be renamed to something more general, like “Report to Mozilla”. The text that pops up could be amended to include the situation of the add-on negatively impacting the browser, and the author not doing anything about it.

I could be mistaken, but I don't think there's any interest in updating the compatibility range for add-ons that simply don't do what they're supposed to anymore [2].

―――――――――――――――――
[1] Bug 1138986.
[2] https://support.mozilla.org/forums/contributors/710243?page=3#post-59567
Severity: enhancement → normal
Status: RESOLVED → UNCONFIRMED
Component: Add-ons Manager → Public Pages
Product: Toolkit → addons.mozilla.org
Resolution: DUPLICATE → ---
Summary: easy way to report broken add-ons → No easy way to report broken, abandoned add-ons to Mozilla
Version: 39 Branch → unspecified
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard

Comment 4

3 years ago
Still no way of reporting abandoned addons.
You need to log in before you can comment on or make changes to this bug.